diff options
Diffstat (limited to 'custom/zsh.nix')
-rw-r--r-- | custom/zsh.nix | 40 |
1 files changed, 2 insertions, 38 deletions
diff --git a/custom/zsh.nix b/custom/zsh.nix index 2f27db6a..de399a11 100644 --- a/custom/zsh.nix +++ b/custom/zsh.nix | |||
@@ -1,48 +1,12 @@ | |||
1 | { config, pkgs, ... }: | 1 | { config, pkgs, ... }: |
2 | let | 2 | |
3 | antigen = pkgs.callPackage (import ./antigen.nix) {}; | 3 | rec { |
4 | in rec { | ||
5 | programs.zsh.enable = true; | 4 | programs.zsh.enable = true; |
6 | programs.zsh.shellAliases = { | ||
7 | less = "less -R"; | ||
8 | ls = "ls --color=auto"; | ||
9 | l = "ls -lhAF"; | ||
10 | ll = "l --color=always L"; | ||
11 | ".." = "cd .."; | ||
12 | "nix-shell" = "nix-shell --command $(getent passwd $LOGNAME | cut -d: -f7)"; | ||
13 | }; | ||
14 | programs.zsh.interactiveShellInit = '' | 5 | programs.zsh.interactiveShellInit = '' |
15 | setopt clobber | 6 | setopt clobber |
16 | setopt nobeep | 7 | setopt nobeep |
17 | |||
18 | alias -g L='|less' | ||
19 | alias -g S='&> /dev/null' | ||
20 | alias -g G='|grep --color=auto' | ||
21 | alias -g B='&> /dev/null &!' | ||
22 | |||
23 | cl() { cd; clear } | ||
24 | ''; | 8 | ''; |
25 | programs.zsh.promptInit = '' | 9 | programs.zsh.promptInit = '' |
26 | bindkey -e | 10 | bindkey -e |
27 | source ${antigen}/antigen.zsh | ||
28 | |||
29 | antigen use oh-my-zsh | ||
30 | antigen bundles <<EOBUNDLES | ||
31 | tmux | ||
32 | zsh-users/zsh-syntax-highlighting | ||
33 | systemd | ||
34 | pass | ||
35 | mosh | ||
36 | emacs | ||
37 | junegunn/fzf | ||
38 | EOBUNDLES | ||
39 | |||
40 | if [[ -e ~/.zsh-theme ]]; then | ||
41 | antigen theme ~ | ||
42 | else | ||
43 | antigen theme jreese | ||
44 | fi | ||
45 | |||
46 | antigen apply | ||
47 | ''; | 11 | ''; |
48 | } | 12 | } |