summaryrefslogtreecommitdiff
path: root/custom/uucp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/uucp.nix')
-rw-r--r--custom/uucp.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/custom/uucp.nix b/custom/uucp.nix
index af87231a..78ab1c03 100644
--- a/custom/uucp.nix
+++ b/custom/uucp.nix
@@ -303,21 +303,21 @@ in {
303 setgid = false; 303 setgid = false;
304 }; 304 };
305 }; 305 };
306 in listToAttrs (map wrapper ["uuxqt" "cu" "uucp" "uuname" "uustat" "uux"]); 306 uucico = {
307 security.wrappers.uucico = { 307 source = pkgs.writeScript ''
308 source = pkgs.writeScript '' 308 #!${pkgs.stdenv.shell}
309 #!${pkgs.stdenv.shell}
310 309
311 ${pkgs.utillinux}/bin/renice -n 15 -p $$ 310 ${pkgs.utillinux}/bin/renice -n 15 -p $$
312 ${pkgs.utillinux}/bin/ionice -c 3 -p $$ 311 ${pkgs.utillinux}/bin/ionice -c 3 -p $$
313 312
314 exec ${pkgs.uucp}/bin/uucico $@ 313 exec ${pkgs.uucp}/bin/uucico $@
315 ''; 314 '';
316 owner = "root"; 315 owner = "root";
317 group = "root"; 316 group = "root";
318 setuid = true; 317 setuid = true;
319 setgid = false; 318 setgid = false;
320 }; 319 };
320 in listToAttrs (map wrapper ["uuxqt" "cu" "uucp" "uuname" "uustat" "uux"]) // { inherit uucico; };
321 321
322 nixpkgs.overlays = [(self: super: { 322 nixpkgs.overlays = [(self: super: {
323 uucp = super.stdenv.lib.overrideDerivation super.uucp (oldAttrs: { 323 uucp = super.stdenv.lib.overrideDerivation super.uucp (oldAttrs: {