diff options
Diffstat (limited to 'custom/opossum-wrapper.nix')
l---------[-rw-r--r--] | custom/opossum-wrapper.nix | 21 |
1 files changed, 1 insertions, 20 deletions
diff --git a/custom/opossum-wrapper.nix b/custom/opossum-wrapper.nix index 2a2a1bff..fe258bb6 100644..120000 --- a/custom/opossum-wrapper.nix +++ b/custom/opossum-wrapper.nix | |||
@@ -1,20 +1 @@ | |||
1 | { stdenv | ../opossum/wrapper.nix \ No newline at end of file | |
2 | , ghcWithPackages | ||
3 | , makeWrapper | ||
4 | , opossum | ||
5 | , additionalPackages ? (p: []) | ||
6 | }: | ||
7 | |||
8 | let | ||
9 | myEnv = ghcWithPackages (p: with p; [ beuteltier opossum ] ++ additionalPackages p); | ||
10 | in stdenv.mkDerivation { | ||
11 | name = "opossum-wrapper"; | ||
12 | |||
13 | nativeBuildInputs = [ makeWrapper ]; | ||
14 | |||
15 | buildCommand = '' | ||
16 | mkdir -p $out/bin | ||
17 | makeWrapper ${opossum}/bin/opossum $out/bin/opossum \ | ||
18 | --set NIX_GHC ${myEnv}/bin/ghc | ||
19 | ''; | ||
20 | } | ||