summaryrefslogtreecommitdiff
path: root/custom/lvm-snapshots.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/lvm-snapshots.nix')
-rw-r--r--custom/lvm-snapshots.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/custom/lvm-snapshots.nix b/custom/lvm-snapshots.nix
index a144f06a..45282d28 100644
--- a/custom/lvm-snapshots.nix
+++ b/custom/lvm-snapshots.nix
@@ -113,5 +113,16 @@ in {
113 where = snapshotMount name; 113 where = snapshotMount name;
114 what = "/dev/" + scfg.VG + "/" + snapshotName name; 114 what = "/dev/" + scfg.VG + "/" + snapshotName name;
115 }) cfg.snapshots; 115 }) cfg.snapshots;
116
117 systemd.automounts = mapAttrsToList (name: scfg: {
118 enable = true;
119
120 automountConfig = {
121 TimeoutIdleSec = "5";
122 DirectoryMode = "0700";
123 };
124
125 where = snapshotMount name;
126 }) cfg.snapshots;
116 }; 127 };
117} 128}