diff options
Diffstat (limited to 'bragi.nix')
-rw-r--r-- | bragi.nix | 14 |
1 files changed, 1 insertions, 13 deletions
@@ -142,10 +142,6 @@ in rec { | |||
142 | systemd.automounts = [ | 142 | systemd.automounts = [ |
143 | { | 143 | { |
144 | wantedBy = [ "multi-user.target" ]; | 144 | wantedBy = [ "multi-user.target" ]; |
145 | where = "/media/odin"; | ||
146 | } | ||
147 | { | ||
148 | wantedBy = [ "multi-user.target" ]; | ||
149 | where = "/media/dellingr"; | 145 | where = "/media/dellingr"; |
150 | automountConfig.TimoutIdleSec = "30s"; | 146 | automountConfig.TimoutIdleSec = "30s"; |
151 | } | 147 | } |
@@ -158,12 +154,6 @@ in rec { | |||
158 | 154 | ||
159 | systemd.mounts = [ | 155 | systemd.mounts = [ |
160 | { | 156 | { |
161 | what = "odin.asgard.yggdrasil:/srv/media"; | ||
162 | where = "/media/odin"; | ||
163 | type = "nfs"; | ||
164 | options = "ro"; | ||
165 | } | ||
166 | { | ||
167 | what = "/dev/disk/by-uuid/6436-3432"; | 157 | what = "/dev/disk/by-uuid/6436-3432"; |
168 | where = "/media/dellingr"; | 158 | where = "/media/dellingr"; |
169 | type = "vfat"; | 159 | type = "vfat"; |
@@ -234,7 +224,7 @@ in rec { | |||
234 | 224 | ||
235 | services.mpd = { | 225 | services.mpd = { |
236 | enable = true; | 226 | enable = true; |
237 | musicDirectory = "/media/odin/music"; | 227 | musicDirectory = "smb://odin.asgard.yggdrasil/media/music"; |
238 | network.listenAddress = "any"; # Just so the module won't produce a bind_to_adress line | 228 | network.listenAddress = "any"; # Just so the module won't produce a bind_to_adress line |
239 | extraConfig = '' | 229 | extraConfig = '' |
240 | bind_to_address "bragi.bragisheimr.yggdrasil" | 230 | bind_to_address "bragi.bragisheimr.yggdrasil" |
@@ -267,8 +257,6 @@ in rec { | |||
267 | group = "audio"; | 257 | group = "audio"; |
268 | }; | 258 | }; |
269 | 259 | ||
270 | security.wrappers = { "mount.nfs".source = "${pkgs.nfs-utils}/bin/mount.nfs"; }; | ||
271 | |||
272 | programs.bash.promptInit = '' | 260 | programs.bash.promptInit = '' |
273 | PROMPT_COLOR="1;31m" | 261 | PROMPT_COLOR="1;31m" |
274 | return $UID && PROMPT_COLOR="1;32m" | 262 | return $UID && PROMPT_COLOR="1;32m" |