summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/bragi.nix b/bragi.nix
index 6672274f..67cd54db 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -146,4 +146,19 @@
146 { domain = "@audio"; item = "nofile"; type = "soft"; value = "99999"; } 146 { domain = "@audio"; item = "nofile"; type = "soft"; value = "99999"; }
147 { domain = "@audio"; item = "nofile"; type = "hard"; value = "99999"; } 147 { domain = "@audio"; item = "nofile"; type = "hard"; value = "99999"; }
148 ]; 148 ];
149 programs.bash.promptInit = ''
150 case "$TERM" in
151 PROMPT_COLOR="1;31m"
152 let $UID && PROMPT_COLOR="1;32m"
153 xterm*|rxvt*|kterm|aterm|gnome*) # Others can go here.
154 PS1="\n\[\033[$PROMPT_COLOR\][\u@\h:\w]\\$\[\033[0m\] "
155 if test "$TERM" = "xterm"; then
156 PS1="\[\033]2;\h:\u:\w\007\]$PS1"
157 fi
158 ;;
159 *)
160 PS1="[\u@\h:\w]$ "
161 ;;
162 esac
163 '';
149} 164}