summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/bragi.nix b/bragi.nix
index de87a761..4d61b61a 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -28,11 +28,11 @@ in rec {
28 28
29 nixpkgs.config.packageOverrides = oldPkgs: 29 nixpkgs.config.packageOverrides = oldPkgs:
30 rec { 30 rec {
31 haskellPackages = oldPkgs.haskellPackages { 31 haskellPackages = oldPkgs.haskellPackages.override {
32 overrides = self: super: { 32 overrides = self: super: {
33 trivmix = self.callPackage ./custom/trivmix/trivmix.nix {}; 33 trivmix = self.callPackage ./custom/trivmix/trivmix.nix {};
34 inherit 34 inherit
35 (lib.mapAttrs (name: drv: oldPkgs.haskell.lib.dontCheck drv) super) 35 (lib.mapAttrs (name: oldPkgs.haskell.lib.dontCheck) super)
36 Glob filelock; 36 Glob filelock;
37 inherit 37 inherit
38 (pkgs.lib.callPackageWith (pkgs // self) ./custom/thermoprint { extraPackages = (p: with p; [ persistent-postgresql ]); }) 38 (pkgs.lib.callPackageWith (pkgs // self) ./custom/thermoprint { extraPackages = (p: with p; [ persistent-postgresql ]); })