summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix19
1 files changed, 10 insertions, 9 deletions
diff --git a/bragi.nix b/bragi.nix
index 21dd9548..f520d05c 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -189,7 +189,8 @@ in rec {
189 enable = true; 189 enable = true;
190 allowPing = true; 190 allowPing = true;
191 allowedTCPPorts = [ 22 # SSH 191 allowedTCPPorts = [ 22 # SSH
192 8080 # thermoprint 192 # 8080 # thermoprint
193 6600 # MPD
193 ]; 194 ];
194 allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh 195 allowedUDPPortRanges = [ { from = 60000; to = 61000; } # mosh
195 ]; 196 ];
@@ -247,14 +248,14 @@ in rec {
247 home = "/var/lib/thermoprint"; 248 home = "/var/lib/thermoprint";
248 }; 249 };
249 250
250 systemd.services."thermoprint" = { 251 # systemd.services."thermoprint" = {
251 serviceConfig = { 252 # serviceConfig = {
252 Type = "simple"; 253 # Type = "simple";
253 ExecStart = ''${thermoprint-servant}/bin/thermoprint --database ${users.extraUsers."thermoprint".home}/database.sqlite /dev/usb/lp0''; 254 # ExecStart = ''${thermoprint-servant}/bin/thermoprint --database ${users.extraUsers."thermoprint".home}/database.sqlite /dev/usb/lp0'';
254 User = users.extraUsers."thermoprint".name; 255 # User = users.extraUsers."thermoprint".name;
255 Group = users.extraUsers."thermoprint".group; 256 # Group = users.extraUsers."thermoprint".group;
256 }; 257 # };
257 }; 258 # };
258 259
259 nix = { 260 nix = {
260 extraOptions = '' 261 extraOptions = ''