diff options
Diffstat (limited to 'bragi.nix')
-rw-r--r-- | bragi.nix | 49 |
1 files changed, 25 insertions, 24 deletions
@@ -10,6 +10,7 @@ in rec { | |||
10 | ./users.nix | 10 | ./users.nix |
11 | ./custom/unit-status-mail.nix | 11 | ./custom/unit-status-mail.nix |
12 | ./custom/trivmix-service.nix | 12 | ./custom/trivmix-service.nix |
13 | ./custom/mpd.nix | ||
13 | ./utils/nix/module.nix | 14 | ./utils/nix/module.nix |
14 | ]; | 15 | ]; |
15 | 16 | ||
@@ -84,27 +85,29 @@ in rec { | |||
84 | }; | 85 | }; |
85 | 86 | ||
86 | nixpkgs.config = { | 87 | nixpkgs.config = { |
87 | packageOverrides = oldPkgs: with oldPkgs; { | 88 | overlays = [ |
88 | haskellPackages = haskellPackages.override { | 89 | (selfPkgs: superPkgs: with superPkgs; { |
89 | overrides = self: super: with self; { | 90 | haskellPackages = haskellPackages.override { |
90 | encoding = haskell.lib.overrideCabal encoding ( oldAttrs: { | 91 | overrides = self: super: with self; { |
91 | src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; | 92 | encoding = haskell.lib.overrideCabal encoding ( oldAttrs: { |
92 | }); | 93 | src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; |
93 | inherit | 94 | }); |
94 | (lib.mapAttrs (name: haskell.lib.dontCheck) super) | 95 | inherit |
95 | Glob filelock hedgehog; | 96 | (lib.mapAttrs (name: haskell.lib.dontCheck) super) |
96 | inherit | 97 | Glob filelock hedgehog; |
97 | (callPackage ./custom/thermoprint { inherit runCommand makeWrapper; extraPackages = (p: with p; [ persistent-postgresql ]); }) | 98 | inherit |
98 | thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; | 99 | (callPackage ./custom/thermoprint { inherit runCommand makeWrapper; extraPackages = (p: with p; [ persistent-postgresql ]); }) |
100 | thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; | ||
101 | }; | ||
99 | }; | 102 | }; |
100 | }; | ||
101 | 103 | ||
102 | jack2Full = jack2Full.override { dbus = null; }; | 104 | jack2Full = jack2Full.override { dbus = null; }; |
103 | 105 | ||
104 | mpd = mpd.override { gmeSupport = false; pulseaudioSupport = false; }; | 106 | mpd = mpd.override { gmeSupport = false; pulseaudioSupport = false; }; |
105 | 107 | ||
106 | inherit (pkgs.haskellPackages) thermoprint-server thermoprint-webgui tprint; | 108 | inherit (pkgs.haskellPackages) thermoprint-server thermoprint-webgui tprint; |
107 | }; | 109 | }) |
110 | ]; | ||
108 | 111 | ||
109 | allowUnfree = true; | 112 | allowUnfree = true; |
110 | }; | 113 | }; |
@@ -225,14 +228,12 @@ in rec { | |||
225 | services.mpd = { | 228 | services.mpd = { |
226 | enable = true; | 229 | enable = true; |
227 | musicDirectory = "smb://odin.asgard.yggdrasil/media/music"; | 230 | musicDirectory = "smb://odin.asgard.yggdrasil/media/music"; |
228 | network.listenAddress = "any"; # Just so the module won't produce a bind_to_adress line | 231 | listenAddresses = [ |
232 | { address = "any"; } | ||
233 | "/var/lib/mpd/socket" | ||
234 | ]; | ||
235 | startWhenNeeded = true; | ||
229 | extraConfig = '' | 236 | extraConfig = '' |
230 | bind_to_address "bragi.bragisheimr.yggdrasil" | ||
231 | bind_to_address "bragi.asgard.yggdrasil" | ||
232 | bind_to_address "localhost" | ||
233 | |||
234 | bind_to_address "/var/lib/mpd/socket" | ||
235 | |||
236 | audio_output { | 237 | audio_output { |
237 | name "JACK" | 238 | name "JACK" |
238 | type "jack" | 239 | type "jack" |