summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/bragi.nix b/bragi.nix
index 7e9ed966..e1a10fb4 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -161,4 +161,30 @@
161 ;; 161 ;;
162 esac 162 esac
163 ''; 163 '';
164
165 networking.interfaces = {
166 "wlp4s0" = {
167 proxyARP = true;
168 };
169 "enp1s0" = {
170 proxyARP = true;
171 useDHCP = false;
172 ipAddress = "10.141.4.1";
173 prefixLength = "24";
174 };
175 };
176
177 services.dhcpd = {
178 enable = true;
179 interfaces = "enp1s0";
180 extraConfig = ''
181 option subnet-mask 255.255.255.0;
182 option broadcast-address 10.141.1.1;
183 option domain-name-servers 10.141.1.1, 8.8.8.8, 8.8.4.4;
184 option domain-name "asgard.yggdrasil";
185 subnet 10.141.4.0 netmask 255.255.255.0 {
186 range 10.141.4.100 10.141.4.254;
187 }
188 '';
189 };
164} 190}