diff options
Diffstat (limited to 'bragi.nix')
-rw-r--r-- | bragi.nix | 12 |
1 files changed, 3 insertions, 9 deletions
@@ -30,19 +30,13 @@ in rec { | |||
30 | rec { | 30 | rec { |
31 | haskellPackages = pkgs.recurseIntoAttrs ( | 31 | haskellPackages = pkgs.recurseIntoAttrs ( |
32 | pkgs.haskellPackages.override { | 32 | pkgs.haskellPackages.override { |
33 | overrides = self: super: let | 33 | overrides = self: super: { |
34 | callPackage = pkgs.lib.callPackageWith ( pkgs // self ); | 34 | trivmix = self.callPackage ./custom/trivmix {}; |
35 | in { | ||
36 | trivmix = callPackage ./custom/trivmix {}; | ||
37 | inherit | 35 | inherit |
38 | (lib.mapAttrs (name: pkgs.haskell.lib.dontCheck) super) | 36 | (lib.mapAttrs (name: pkgs.haskell.lib.dontCheck) super) |
39 | Glob filelock; | 37 | Glob filelock; |
40 | inherit | 38 | inherit |
41 | ((import ./custom/thermoprint) { | 39 | ((import ./custom/thermoprint) { extraPackages = (p: with p; [ persistent-postgresql ]); }) |
42 | inherit (pkgs) stdenv; | ||
43 | haskellPackages = self; | ||
44 | extraPackages = (p: with p; [ persistent-postgresql ]); | ||
45 | }) | ||
46 | thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; | 40 | thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; |
47 | }; | 41 | }; |
48 | } | 42 | } |