summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix21
1 files changed, 13 insertions, 8 deletions
diff --git a/bragi.nix b/bragi.nix
index 10f42e88..932d0cdf 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -7,7 +7,6 @@ in rec {
7 imports = 7 imports =
8 [ 8 [
9 ./bragi-hw.nix 9 ./bragi-hw.nix
10 ./customized/autofs.nix
11 ./custom/zsh.nix 10 ./custom/zsh.nix
12 ./users.nix 11 ./users.nix
13 ]; 12 ];
@@ -243,12 +242,18 @@ in rec {
243 home = "/var/lib/thermoprint"; 242 home = "/var/lib/thermoprint";
244 }; 243 };
245 244
246 systemd.services."thermoprint" = { 245 systemd.services."thermoprint" = {
247 serviceConfig = { 246 serviceConfig = {
248 Type = "simple"; 247 Type = "simple";
249 ExecStart = ''${thermoprint-servant}/bin/thermoprint --database ${users.extraUsers."thermoprint".home}/database.sqlite /dev/usb/lp0''; 248 ExecStart = ''${thermoprint-servant}/bin/thermoprint --database ${users.extraUsers."thermoprint".home}/database.sqlite /dev/usb/lp0'';
250 User = users.extraUsers."thermoprint".name; 249 User = users.extraUsers."thermoprint".name;
251 Group = users.extraUsers."thermoprint".group; 250 Group = users.extraUsers."thermoprint".group;
252 };
253 }; 251 };
252 };
253
254 nix = {
255 extraOptions = ''
256 binary-caches-parallel-connections = 10
257 '';
258 };
254} 259}