summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/bragi.nix b/bragi.nix
index ee35f378..842302ed 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -2,6 +2,7 @@
2 2
3let 3let
4 trivmixService = opts: (pkgs.callPackage ./custom/trivmix-service.nix opts).out; 4 trivmixService = opts: (pkgs.callPackage ./custom/trivmix-service.nix opts).out;
5 thermoprint-servant = (pkgs.callPackage ./custom/thermoprint {}).thermoprint-servant;
5in { 6in {
6 imports = 7 imports =
7 [ 8 [
@@ -239,4 +240,21 @@ in {
239 inherit (template) shell; 240 inherit (template) shell;
240 openssh.authorizedKeys.keyFiles = template.openssh.authorizedKeys.keyFiles; 241 openssh.authorizedKeys.keyFiles = template.openssh.authorizedKeys.keyFiles;
241 }; 242 };
243
244 users.extraUsers."thermoprint" = {
245 name = "thermoprint";
246 group = "lp";
247 isSystemUser = true;
248 createHome = true;
249 home = "/var/thermoprint";
250 };
251
252 systemd.services."thermoprint" = {
253 serviceConfig = {
254 Type = "simple";
255 ExecStart = ''${thermoprint-servant}/bin/thermoprint --database /var/thermoprint/database.sqlite'';
256 User = "thermoprint";
257 Group = "lp";
258 };
259 };
242} 260}