summaryrefslogtreecommitdiff
path: root/bragi-hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi-hw.nix')
-rw-r--r--bragi-hw.nix34
1 files changed, 0 insertions, 34 deletions
diff --git a/bragi-hw.nix b/bragi-hw.nix
deleted file mode 100644
index f355ffa0..00000000
--- a/bragi-hw.nix
+++ /dev/null
@@ -1,34 +0,0 @@
1{ config, lib, pkgs, ... }:
2
3{
4 imports =
5 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
6 ];
7
8 boot.initrd.availableKernelModules = [ "ahci" "ohci_pci" "ehci_pci" "usb_storage" ];
9 boot.kernelModules = [ "kvm-amd" ];
10 boot.extraModulePackages = [ ];
11 boot.loader.grub.device = "/dev/disk/by-id/ata-Crucial_CT256M550SSD3_15010E5F81A6";
12
13 fileSystems."/" =
14 { device = "/dev/disk/by-uuid/15fc072d-5fdf-4ec7-b029-50d09b4dc5ea";
15 fsType = "ext4";
16 };
17
18 fileSystems."/home" =
19 { device = "/dev/disk/by-uuid/c76d9b7c-ba84-49d3-a7c9-b53e201b76c6";
20 fsType = "ext4";
21 };
22
23 swapDevices =
24 [ { device = "/dev/disk/by-uuid/2b13b997-59e8-4f59-bc84-554eb0df7482"; }
25 ];
26
27 nix.maxJobs = 2;
28
29 boot.loader.grub.extraConfig = "serial; terminal_output.serial";
30 boot.kernelParams = [ "console=ttyS0,115200"
31 ];
32
33 nixpkgs.system = "i686-linux";
34}