summaryrefslogtreecommitdiff
path: root/accounts/mherold@eostre.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/mherold@eostre.nix')
-rw-r--r--accounts/mherold@eostre.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/accounts/mherold@eostre.nix b/accounts/mherold@eostre.nix
new file mode 100644
index 00000000..ab1bf154
--- /dev/null
+++ b/accounts/mherold@eostre.nix
@@ -0,0 +1,25 @@
1{ userName, pkgs, lib, ... }: {
2 config = {
3 users.users.${userName} = {
4 hashedPassword = lib.mkForce "$6$rounds=500000$TaikR1KI4CGveV0a$jLrBjNScflgniUiy87zxQ.IjnyK8K7FbYTW7L0k0EBVrdiImds26WwNjA6DrQpENALwPMzJVIK5BTie17fFVG.";
5 };
6
7 home-manager.users.${userName} = {
8 nixpkgs.config = {
9 allowUnfree = true;
10 };
11
12 home.packages = with pkgs; [
13 thunderbird libreoffice element-desktop keepassxc
14 ];
15
16 programs.firefox = {
17 enable = true;
18 profiles.default.settings = {
19 "dom.security.https_only_mode" = true;
20 "browser.cache.disk.enable" = false;
21 };
22 };
23 };
24 };
25}