summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix80
1 files changed, 80 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
new file mode 100644
index 00000000..7faef31a
--- /dev/null
+++ b/accounts/gkleen@sif/systemd.nix
@@ -0,0 +1,80 @@
1{ pkgs, config, userName, ... }:
2let
3 xmobar = import ./xmobar pkgs.haskellPackages;
4 cfg = config.home-manager.users.${userName};
5in {
6 services = {
7 sync-keepass = {
8 Service = {
9 Type = "oneshot";
10 WorkingDirectory = "~";
11 ExecStart = "${pkgs.lftp}/bin/lftp -f ${./store.kdbx.lftp}";
12 };
13 };
14 emacs = {
15 Unit = {
16 After = ["graphical-session-pre.target"];
17 };
18 };
19 trayer = {
20 Service = {
21 Type = "simple";
22 WorkingDirectory = "~";
23 ExecStart = "${pkgs.trayer}/bin/trayer --edge top --align right --SetDockType true --SetPartialStrut true --expand true --width 8 --tint 0x000000 --alpha 0 --transparent true --height 32 --monitor primary";
24 Restart = "always";
25 };
26 Install = {
27 WantedBy = ["graphical-session.target"];
28 };
29 };
30 xmobar = {
31 Service = {
32 Type = "simple";
33 WorkingDirectory = "~";
34 ExecStart = "${xmobar}/bin/xmobar";
35 Restart = "always";
36 Environment = "PATH=${pkgs.worktime}/bin:${pkgs.openssh}/bin";
37
38 };
39 Install = {
40 WantedBy = ["graphical-session.target"];
41 };
42 };
43 dunst = {
44 Service = {
45 Restart = "always";
46 };
47 Install = {
48 WantedBy = ["graphical-session.target"];
49 };
50 };
51 xiccd = {
52 Service = {
53 Type = "simple";
54 WorkingDirectory = "~";
55 ExecStart = "${pkgs.xiccd}/bin/xiccd";
56 Restart = "always";
57 };
58 };
59 };
60 timers = {
61 sync-keepass = {
62 Timer = {
63 OnActiveSec = "1m";
64 OnUnitActiveSec = "1m";
65 };
66
67 Install = {
68 WantedBy = ["default.target"];
69 };
70 };
71 };
72 targets = {
73 graphical-session = {
74 Unit = {
75 BindsTo = ["default.target"];
76 After = ["basic.target"];
77 };
78 };
79 };
80}