summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
index 92404b61..be016b09 100644
--- a/accounts/gkleen@sif/systemd.nix
+++ b/accounts/gkleen@sif/systemd.nix
@@ -188,6 +188,22 @@ in {
188 RuntimeDirectory = "swayidle"; 188 RuntimeDirectory = "swayidle";
189 }; 189 };
190 }; 190 };
191 psi-notify = {
192 Install = {
193 WantedBy = ["graphical-session.target"];
194 };
195 Unit = {
196 Requires = ["graphical-session-pre.target"];
197 After = ["graphical-session-pre.target"];
198 };
199 Service = {
200 ExecStart = lib.getExe pkgs.psi-notify;
201 ExecReload = "${pkgs.coreutils}/bin/kill -HUP $MAINPID";
202 Type = "notify";
203 Restart = "always";
204 WatchdogSec = "2s";
205 };
206 };
191 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" { 207 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" {
192 Unit = { 208 Unit = {
193 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"]; 209 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"];