summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
index e5d1681c..5608b833 100644
--- a/accounts/gkleen@sif/systemd.nix
+++ b/accounts/gkleen@sif/systemd.nix
@@ -1,4 +1,4 @@
1{ pkgs, lib, config, userName, ... }: 1{ pkgs, lib, config, utils, userName, ... }:
2let 2let
3 inherit (lib) listToAttrs nameValuePair; 3 inherit (lib) listToAttrs nameValuePair;
4 4
@@ -205,6 +205,11 @@ in {
205 RuntimeDirectory = "swayidle"; 205 RuntimeDirectory = "swayidle";
206 }; 206 };
207 }; 207 };
208 poweralertd = {
209 Service = {
210 ExecStart = lib.mkForce "${lib.getExe pkgs.poweralertd} ${utils.escapeSystemdExecArgs ["-i" "mouse"]}";
211 };
212 };
208 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" { 213 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" {
209 Unit = { 214 Unit = {
210 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"]; 215 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"];