summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix42
1 files changed, 17 insertions, 25 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
index 33bf7ef2..34f52172 100644
--- a/accounts/gkleen@sif/systemd.nix
+++ b/accounts/gkleen@sif/systemd.nix
@@ -126,15 +126,6 @@ in {
126 After = ["graphical-session-pre.target"]; 126 After = ["graphical-session-pre.target"];
127 }; 127 };
128 }; 128 };
129 dunst = {
130 Service = {
131 ExecStart = lib.mkForce "${cfg.services.dunst.package}/bin/dunst";
132 Restart = "always";
133 };
134 Install = {
135 WantedBy = ["graphical-session.target"];
136 };
137 };
138 keepassxc = { 129 keepassxc = {
139 Service = { 130 Service = {
140 Type = "dbus"; 131 Type = "dbus";
@@ -204,20 +195,6 @@ in {
204 WatchdogSec = "2s"; 195 WatchdogSec = "2s";
205 }; 196 };
206 }; 197 };
207 polkit-gnome-authentication-agent-1 = {
208 Install = {
209 WantedBy = ["graphical-session.target"];
210 };
211 Unit = {
212 PartOf = ["graphical-session.target"];
213 Requires = ["graphical-session-pre.target"];
214 After = ["graphical-session-pre.target"];
215 };
216 Service = {
217 ExecStart = "${pkgs.polkit_gnome}/libexec/polkit-gnome-authentication-agent-1";
218 Restart = "on-failure";
219 };
220 };
221 gtklock = { 198 gtklock = {
222 Unit = { 199 Unit = {
223 Requisite = ["graphical-session.target"]; 200 Requisite = ["graphical-session.target"];
@@ -247,7 +224,7 @@ in {
247 fi 224 fi
248 monitors+=([$monitor]="$blurred_path") 225 monitors+=([$monitor]="$blurred_path")
249 done < <(wpaperctl all-wallpapers -j | jq -c ".[]") 226 done < <(wpaperctl all-wallpapers -j | jq -c ".[]")
250 wait 227 # wait
251 228
252 cp --no-preserve=mode ${pkgs.writeText "gtklock.css" '' 229 cp --no-preserve=mode ${pkgs.writeText "gtklock.css" ''
253 #window-box { 230 #window-box {
@@ -273,7 +250,7 @@ in {
273 ]; 250 ];
274 NotifyAccess = "all"; 251 NotifyAccess = "all";
275 ExecStart = ''${lib.getExe pkgs.gtklock} -s "''${RUNTIME_DIRECTORY}/style.css" -L ${pkgs.writeShellScript "after-lock" '' 252 ExecStart = ''${lib.getExe pkgs.gtklock} -s "''${RUNTIME_DIRECTORY}/style.css" -L ${pkgs.writeShellScript "after-lock" ''
276 ${cfg.wayland.windowManager.hyprland.package}/bin/hyprctl dispatch dpms off 253 ${lib.getExe cfg.programs.niri.package} msg action power-off-monitors
277 ${config.systemd.package}/bin/systemd-notify --ready 254 ${config.systemd.package}/bin/systemd-notify --ready
278 ''}''; 255 ''}'';
279 }; 256 };
@@ -322,6 +299,21 @@ in {
322 ExecStopPost = "${pkgs.coreutils}/bin/rm -rfv \"$CACHE_DIRECTORY\""; 299 ExecStopPost = "${pkgs.coreutils}/bin/rm -rfv \"$CACHE_DIRECTORY\"";
323 }; 300 };
324 }; 301 };
302 wpaperd = {
303 Install = {
304 WantedBy = ["graphical-session.target"];
305 };
306 Unit = {
307 BindsTo = ["graphical-session-pre.target"];
308 After = ["graphical-session-pre.target"];
309 };
310 Service = {
311 ExecStart = lib.getExe cfg.programs.wpaperd.package;
312 Type = "simple";
313 Restart = "always";
314 RestartSec = "2s";
315 };
316 };
325 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" { 317 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" {
326 Unit = { 318 Unit = {
327 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"]; 319 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"];