summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/ssh-hosts.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/ssh-hosts.nix')
-rw-r--r--accounts/gkleen@sif/ssh-hosts.nix237
1 files changed, 237 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/ssh-hosts.nix b/accounts/gkleen@sif/ssh-hosts.nix
new file mode 100644
index 00000000..1b9fb842
--- /dev/null
+++ b/accounts/gkleen@sif/ssh-hosts.nix
@@ -0,0 +1,237 @@
1{
2 "git.ymir" =
3 { hostname = "ymir.yggdrasil.li";
4 user = "gitolite";
5 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
6 };
7 "git.yggdrasil.li" =
8 { user = "gitolite";
9 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
10 };
11 "git.rheperire.org" =
12 { user = "gitolite";
13 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
14 };
15 "borg.munin" =
16 { hostname = "u120515.your-storagebox.de";
17 user = "u120515";
18 identityFile = "~/.ssh/borg.munin";
19 port = 23;
20 };
21 "munin" =
22 { hostname = "u120515.your-storagebox.de";
23 user = "u120515";
24 identityFile = "~/.ssh/munin";
25 };
26 "ymir" =
27 { hostname = "ymir.yggdrasil.li";
28 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
29 };
30 "surtr" =
31 { hostname = "surtr.yggdrasil.li";
32 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
33 };
34 "odin" =
35 { hostname = "odin.asgard.yggdrasil";
36 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
37 };
38 "init.odin" =
39 { hostname = "odin.asgard.yggdrasil";
40 user = "root";
41 identityFile = "~/.ssh/rsa.gkleen@hel.midgard.yggdrasil";
42 extraOptions = {
43 StrictHostKeyChecking = "off";
44 };
45 };
46 "heimdallr" =
47 { hostname = "heimdallr.asgard.yggdrasil";
48 user = "root";
49 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
50 };
51 "gitlab2.rz.ifi.lmu.de" =
52 { user = "git";
53 identityFile = "~/.ssh/gkleen@gitlab2.rz.ifi.lmu.de";
54 };
55 "gitlab2.cip.ifi.lmu.de" =
56 { user = "git";
57 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
58 };
59 "hel".hostname = "hel.midgard.yggdrasil";
60 "blackbeard" =
61 { hostname = "blackbeard.tcs.ifi.lmu.de";
62 user = "pi";
63 identityFile = "~/.ssh/blackbeard";
64 };
65 "github.com" =
66 { user = "git";
67 identityFile = "~/.ssh/gkleen@github.com";
68 };
69 "ullr.playat.ch" =
70 { hostname = "ullr.playat.ch";
71 user = "minecraft";
72 identityFile = "~/.ssh/minecraft@ullr.playat.ch";
73 };
74 "ullr" =
75 { hostname = "185.170.112.70";
76 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
77 };
78 "testworx" =
79 { hostname = "testworx.tcs.ifi.lmu.de";
80 user = "root";
81 port = 30363;
82 identityFile = "~/.ssh/testworx";
83 };
84 "remote.cip.ifi.lmu.de" =
85 { user = "kleen";
86 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
87 };
88 "uniworx3" =
89 { hostname = "uniworx3.ifi.lmu.de";
90 user = "root";
91 identityFile = "~/.ssh/uni2work";
92 };
93 "uniworx4" =
94 { hostname = "uniworx4.ifi.lmu.de";
95 user = "root";
96 identityFile = "~/.ssh/uni2work";
97 };
98 "jump.uniworx4" =
99 { hostname = "uniworx4.ifi.lmu.de";
100 user = "sshjump";
101 identityFile = "~/.ssh/sshjump.uni2work";
102 };
103 "uni2workgw" =
104 { hostname = "uni2workgw.ifi.lmu.de";
105 user = "root";
106 identityFile = "~/.ssh/uni2work";
107 };
108 "uniworxdb2" =
109 { hostname = "uniworxdb2";
110 proxyJump = "uniworx4";
111 user = "root";
112 identityFile = "~/.ssh/uni2work";
113 };
114 "uniworx5" =
115 { hostname = "uniworx5.ifi.lmu.de";
116 user = "root";
117 identityFile = "~/.ssh/uni2work";
118 };
119 "gate2" =
120 { hostname = "gate2.tcs.ifi.lmu.de";
121 user = "gkleen";
122 identityFile = "~/.ssh/tcs";
123 serverAliveInterval = 0;
124 };
125 "proxy.gate2" =
126 { hostname = "gate2.tcs.ifi.lmu.de";
127 user = "gkleen";
128 identityFile = "~/.ssh/proxy.gkleen@tcs.ifi.lmu.de";
129 dynamicForwards = [ { port = 8118; } ];
130 serverAliveInterval = 0;
131 extraOptions = {
132 ExitOnForwardFailure = "yes";
133 };
134 };
135 "jump.gate2" =
136 { hostname = "gate2.tcs.ifi.lmu.de";
137 user = "gkleen";
138 identityFile = "~/.ssh/proxy.gkleen@tcs.ifi.lmu.de";
139 serverAliveInterval = 0;
140 extraOptions = {
141 ExitOnForwardFailure = "yes";
142 };
143 };
144 "gate" =
145 { hostname = "gate.tcs.ifi.lmu.de";
146 user = "gkleen";
147 identityFile = "~/.ssh/tcs";
148 };
149 "proxy.gate" =
150 { hostname = "gate.tcs.ifi.lmu.de";
151 user = "gkleen";
152 identityFile = "~/.ssh/proxy.gkleen@tcs.ifi.lmu.de";
153 dynamicForwards = [ { port = 8118; } ];
154 extraOptions = {
155 ExitOnForwardFailure = "yes";
156 };
157 };
158 "jump.gate" =
159 { hostname = "gate.tcs.ifi.lmu.de";
160 user = "gkleen";
161 identityFile = "~/.ssh/proxy.gkleen@tcs.ifi.lmu.de";
162 extraOptions = {
163 ExitOnForwardFailure = "yes";
164 };
165 };
166 "oregon" =
167 { hostname = "oregon.tcs.ifi.lmu.de";
168 user = "root";
169 identityFile = "~/.ssh/tcs";
170 };
171 "proxy.oregon" =
172 { hostname = "oregon.tcs.ifi.lmu.de";
173 user = "root";
174 identityFile = "~/.ssh/tcs";
175 dynamicForwards = [ { port = 8113; } ];
176 extraOptions = {
177 ExitOnForwardFailure = "yes";
178 };
179 };
180 "witbank" =
181 { hostname = "witbank.tcs.ifi.lmu.de";
182 user = "uni2work";
183 identityFile = "~/.ssh/letz";
184 };
185 "git.odin" =
186 { hostname = "odin.asgard.yggdrasil";
187 user = "gitolite";
188 };
189 "notmuch.odin" =
190 { hostname = "odin.asgard.yggdrasil";
191 identityFile = "~/.ssh/notmuch.odin.asgard.yggdrasil";
192 };
193 "status.odin" =
194 { hostname = "odin.asgard.yggdrasil";
195 identityFile = "~/.ssh/status.odin.asgard.yggdrasil";
196 extraOptions.ControlPath = "~/.ssh/status-%r@%n:%p";
197 };
198 "moden" =
199 { hostname = "oristano.tcs.ifi.lmu.de";
200 user = "gkleen";
201 port = 30363;
202 identityFile = "~/.ssh/gkleen@oristano.tcs.ifi.lmu.de";
203 };
204 "ubuntu1804" =
205 { hostname = "192.168.122.30";
206 identityFile = "~/.ssh/gkleen@sif.midgard.yggdrasil";
207 forwardAgent = true;
208 };
209 "gitlab.haskell.org" =
210 { hostname = "gitlab.haskell.org";
211 identityFile = "~/.ssh/gkleen@gitlab.haskell.org";
212 };
213 "gitlab.lrz.de" =
214 { hostname = "gitlab.lrz.de";
215 user = "git";
216 identityFile = "~/.ssh/gkleen@gitlab.lrz.de";
217 };
218 "uni2work-dev1" =
219 { hostname = "uni2work-dev1.ifi.lmu.de";
220 user = "gkleen";
221 identityFile = "~/.ssh/uni2work";
222 proxyJump = "jump.uniworx4";
223 localForwards = [
224 { bind = { address = "localhost"; port = 3940; };
225 host = { address = "localhost"; port = 3940; };
226 }
227 { bind = { address = "localhost"; port = 9020; };
228 host = { address = "localhost"; port = 9020; };
229 }
230 ];
231 remoteForwards = [
232 { host = { address = "/run/user/1000/emacs/server"; };
233 bind = { address = "/home/gkleen/.ssh/emacs-server"; };
234 }
235 ];
236 };
237}