diff options
Diffstat (limited to 'accounts/gkleen@sif/niri/waybar.nix')
-rw-r--r-- | accounts/gkleen@sif/niri/waybar.nix | 4 |
1 files changed, 1 insertions, 3 deletions
diff --git a/accounts/gkleen@sif/niri/waybar.nix b/accounts/gkleen@sif/niri/waybar.nix index 56a1b648..3f1f8119 100644 --- a/accounts/gkleen@sif/niri/waybar.nix +++ b/accounts/gkleen@sif/niri/waybar.nix | |||
@@ -61,7 +61,7 @@ in { | |||
61 | text = f"<span font=\"Symbols Nerd Font Mono\" size=\"90%\">{icon}</span>" # noqa: E501 | 61 | text = f"<span font=\"Symbols Nerd Font Mono\" size=\"90%\">{icon}</span>" # noqa: E501 |
62 | if is_silent: | 62 | if is_silent: |
63 | text = f"<span color=\"#ffffff\">{text}</span>" | 63 | text = f"<span color=\"#ffffff\">{text}</span>" |
64 | print(json.dumps({'text': text}, separators=(',', ':')), flush=True) # noqa: E501 | 64 | print(json.dumps({'text': text, 'tooltip': ', '.join(modes)}, separators=(',', ':')), flush=True) # noqa: E501 |
65 | 65 | ||
66 | async def on_properties_changed(interface_name, changed_properties, invalidated_properties): # noqa: E501 | 66 | async def on_properties_changed(interface_name, changed_properties, invalidated_properties): # noqa: E501 |
67 | if "Modes" not in invalidated_properties: | 67 | if "Modes" not in invalidated_properties: |
@@ -124,13 +124,11 @@ in { | |||
124 | interval = 60; | 124 | interval = 60; |
125 | exec = "${lib.getExe pkgs.worktime} time --waybar"; | 125 | exec = "${lib.getExe pkgs.worktime} time --waybar"; |
126 | return-type = "json"; | 126 | return-type = "json"; |
127 | tooltip = false; | ||
128 | }; | 127 | }; |
129 | "custom/worktime-today" = { | 128 | "custom/worktime-today" = { |
130 | interval = 60; | 129 | interval = 60; |
131 | exec = "${lib.getExe pkgs.worktime} today --waybar"; | 130 | exec = "${lib.getExe pkgs.worktime} today --waybar"; |
132 | return-type = "json"; | 131 | return-type = "json"; |
133 | tooltip = false; | ||
134 | }; | 132 | }; |
135 | "niri/workspaces" = { | 133 | "niri/workspaces" = { |
136 | ignore = ["eff" "pwctl" "kpxc" "bmgr" "edit" "term"]; | 134 | ignore = ["eff" "pwctl" "kpxc" "bmgr" "edit" "term"]; |