diff options
Diffstat (limited to 'accounts/gkleen@sif/niri/waybar.nix')
-rw-r--r-- | accounts/gkleen@sif/niri/waybar.nix | 16 |
1 files changed, 11 insertions, 5 deletions
diff --git a/accounts/gkleen@sif/niri/waybar.nix b/accounts/gkleen@sif/niri/waybar.nix index c3820508..3f1f8119 100644 --- a/accounts/gkleen@sif/niri/waybar.nix +++ b/accounts/gkleen@sif/niri/waybar.nix | |||
@@ -61,7 +61,7 @@ in { | |||
61 | text = f"<span font=\"Symbols Nerd Font Mono\" size=\"90%\">{icon}</span>" # noqa: E501 | 61 | text = f"<span font=\"Symbols Nerd Font Mono\" size=\"90%\">{icon}</span>" # noqa: E501 |
62 | if is_silent: | 62 | if is_silent: |
63 | text = f"<span color=\"#ffffff\">{text}</span>" | 63 | text = f"<span color=\"#ffffff\">{text}</span>" |
64 | print(json.dumps({'text': text}, separators=(',', ':')), flush=True) # noqa: E501 | 64 | print(json.dumps({'text': text, 'tooltip': ', '.join(modes)}, separators=(',', ':')), flush=True) # noqa: E501 |
65 | 65 | ||
66 | async def on_properties_changed(interface_name, changed_properties, invalidated_properties): # noqa: E501 | 66 | async def on_properties_changed(interface_name, changed_properties, invalidated_properties): # noqa: E501 |
67 | if "Modes" not in invalidated_properties: | 67 | if "Modes" not in invalidated_properties: |
@@ -122,13 +122,13 @@ in { | |||
122 | }; | 122 | }; |
123 | "custom/worktime" = { | 123 | "custom/worktime" = { |
124 | interval = 60; | 124 | interval = 60; |
125 | exec = lib.getExe pkgs.worktime; | 125 | exec = "${lib.getExe pkgs.worktime} time --waybar"; |
126 | tooltip = false; | 126 | return-type = "json"; |
127 | }; | 127 | }; |
128 | "custom/worktime-today" = { | 128 | "custom/worktime-today" = { |
129 | interval = 60; | 129 | interval = 60; |
130 | exec = "${lib.getExe pkgs.worktime} today"; | 130 | exec = "${lib.getExe pkgs.worktime} today --waybar"; |
131 | tooltip = false; | 131 | return-type = "json"; |
132 | }; | 132 | }; |
133 | "niri/workspaces" = { | 133 | "niri/workspaces" = { |
134 | ignore = ["eff" "pwctl" "kpxc" "bmgr" "edit" "term"]; | 134 | ignore = ["eff" "pwctl" "kpxc" "bmgr" "edit" "term"]; |
@@ -323,6 +323,12 @@ in { | |||
323 | #idle_inhibitor.activated { | 323 | #idle_inhibitor.activated { |
324 | color: @white; | 324 | color: @white; |
325 | } | 325 | } |
326 | #custom-worktime.running, #custom-worktime-today.running { | ||
327 | color: @white; | ||
328 | } | ||
329 | #custom-worktime.over, #custom-worktime-today.over { | ||
330 | color: @orange; | ||
331 | } | ||
326 | 332 | ||
327 | #idle_inhibitor { | 333 | #idle_inhibitor { |
328 | padding-top: 1px; | 334 | padding-top: 1px; |