diff options
Diffstat (limited to 'accounts/gkleen@sif/niri/mako.nix')
-rw-r--r-- | accounts/gkleen@sif/niri/mako.nix | 50 |
1 files changed, 50 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/niri/mako.nix b/accounts/gkleen@sif/niri/mako.nix new file mode 100644 index 00000000..8abf14d8 --- /dev/null +++ b/accounts/gkleen@sif/niri/mako.nix | |||
@@ -0,0 +1,50 @@ | |||
1 | { config, lib, ... }: | ||
2 | { | ||
3 | config = { | ||
4 | services.mako = { | ||
5 | enable = true; | ||
6 | font = "Fira Sans 10"; | ||
7 | format = "<i>%s</i>\\n%b"; | ||
8 | margin = "2"; | ||
9 | maxVisible = -1; | ||
10 | backgroundColor = "#000000dd"; | ||
11 | progressColor = "source #223544ff"; | ||
12 | width = 384; | ||
13 | extraConfig = '' | ||
14 | outer-margin=1 | ||
15 | max-history=100 | ||
16 | |||
17 | [grouped] | ||
18 | format=<b>(%g)</b> <i>%s</i>\n%b | ||
19 | |||
20 | [urgency=low] | ||
21 | text-color=#999999ff | ||
22 | |||
23 | [urgency=critical] | ||
24 | background-color=#900000dd | ||
25 | |||
26 | [app-name=Element] | ||
27 | group-by=summary | ||
28 | |||
29 | [mode=silent] | ||
30 | invisible=1 | ||
31 | ''; | ||
32 | }; | ||
33 | systemd.user.services.mako = { | ||
34 | Unit = { | ||
35 | Description = "Mako notification daemon"; | ||
36 | PartOf = [ "graphical-session.target" ]; | ||
37 | }; | ||
38 | Install = { | ||
39 | WantedBy = [ "graphical-session.target" ]; | ||
40 | }; | ||
41 | Service = { | ||
42 | Type = "dbus"; | ||
43 | BusName = "org.freedesktop.Notifications"; | ||
44 | ExecStart = lib.getExe config.services.mako.package; | ||
45 | RestartSec = 5; | ||
46 | Restart = "always"; | ||
47 | }; | ||
48 | }; | ||
49 | }; | ||
50 | } | ||