summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/niri/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/niri/default.nix')
-rw-r--r--accounts/gkleen@sif/niri/default.nix29
1 files changed, 15 insertions, 14 deletions
diff --git a/accounts/gkleen@sif/niri/default.nix b/accounts/gkleen@sif/niri/default.nix
index 841c972a..cc6c85c3 100644
--- a/accounts/gkleen@sif/niri/default.nix
+++ b/accounts/gkleen@sif/niri/default.nix
@@ -4,7 +4,7 @@ let
4 terminal = lib.getExe config.programs.kitty.package; 4 terminal = lib.getExe config.programs.kitty.package;
5 lightctl = lib.getExe' config.services.avizo.package "lightctl"; 5 lightctl = lib.getExe' config.services.avizo.package "lightctl";
6 volumectl = lib.getExe' config.services.avizo.package "volumectl"; 6 volumectl = lib.getExe' config.services.avizo.package "volumectl";
7 dunstctl = lib.getExe' config.services.dunst.package "dunstctl"; 7 makoctl = lib.getExe' config.services.mako.package "makoctl";
8 loginctl = lib.getExe' hostConfig.systemd.package "loginctl"; 8 loginctl = lib.getExe' hostConfig.systemd.package "loginctl";
9 systemctl = lib.getExe' hostConfig.systemd.package "systemctl"; 9 systemctl = lib.getExe' hostConfig.systemd.package "systemctl";
10 10
@@ -121,6 +121,7 @@ let
121in { 121in {
122 imports = [ 122 imports = [
123 ./waybar.nix 123 ./waybar.nix
124 ./mako.nix
124 ]; 125 ];
125 126
126 config = { 127 config = {
@@ -244,13 +245,13 @@ in {
244 }; 245 };
245 246
246 window-rules = [ 247 window-rules = [
247 { 248 # {
248 geometry-corner-radius = 249 # geometry-corner-radius =
249 let 250 # let
250 allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; }; 251 # allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; };
251 in allCorners 4.; 252 # in allCorners 4.;
252 clip-to-geometry = true; 253 # clip-to-geometry = true;
253 } 254 # }
254 { 255 {
255 matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ]; 256 matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ];
256 open-on-workspace = "pwctl"; 257 open-on-workspace = "pwctl";
@@ -264,7 +265,7 @@ in {
264 excludes = [ 265 excludes = [
265 { title = "^Unlock Database.*"; } 266 { title = "^Unlock Database.*"; }
266 { title = "^Access Request.*"; } 267 { title = "^Access Request.*"; }
267 { title = "^Passkey credentials.*"; } 268 { title = ".*Passkey credentials$"; }
268 ]; 269 ];
269 open-on-workspace = "kpxc"; 270 open-on-workspace = "kpxc";
270 open-focused = false; 271 open-focused = false;
@@ -273,7 +274,7 @@ in {
273 matches = [ 274 matches = [
274 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Unlock Database.*"; } 275 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Unlock Database.*"; }
275 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Access Request.*"; } 276 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Access Request.*"; }
276 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Passkey credentials.*"; } 277 { app-id = "^org\.keepassxc\.KeePassXC$"; title = ".*Passkey credentials$"; }
277 ]; 278 ];
278 open-focused = true; 279 open-focused = true;
279 } 280 }
@@ -519,10 +520,10 @@ in {
519 allow-when-locked = true; 520 allow-when-locked = true;
520 }; 521 };
521 522
522 "Mod+Semicolon".action = spawn dunstctl "close"; 523 "Mod+Semicolon".action = spawn makoctl "dismiss";
523 "Mod+Shift+Semicolon".action = spawn dunstctl "close-all"; 524 "Mod+Shift+Semicolon".action = spawn makoctl "dismiss" "--all";
524 "Mod+Period".action = spawn dunstctl "context"; 525 "Mod+Period".action = spawn makoctl (lib.getExe config.programs.fuzzel.package) "--dmenu";
525 "Mod+Comma".action = spawn dunstctl "history-pop"; 526 "Mod+Comma".action = spawn makoctl "restore";
526 527
527 "Mod+Control+A".action = focus-or-spawn-action-app_id "com.saivert.pwvucontrol" "pwctl" "pwvucontrol"; 528 "Mod+Control+A".action = focus-or-spawn-action-app_id "com.saivert.pwvucontrol" "pwctl" "pwvucontrol";
528 "Mod+Control+P".action = focus-or-spawn-action-app_id "org.keepassxc.KeePassXC" "kpxc" "keepassxc"; 529 "Mod+Control+P".action = focus-or-spawn-action-app_id "org.keepassxc.KeePassXC" "kpxc" "keepassxc";