summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/niri/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/niri/default.nix')
-rw-r--r--accounts/gkleen@sif/niri/default.nix33
1 files changed, 27 insertions, 6 deletions
diff --git a/accounts/gkleen@sif/niri/default.nix b/accounts/gkleen@sif/niri/default.nix
index 40f733e8..841c972a 100644
--- a/accounts/gkleen@sif/niri/default.nix
+++ b/accounts/gkleen@sif/niri/default.nix
@@ -197,8 +197,8 @@ in {
197 focus-ring = { 197 focus-ring = {
198 width = 2; 198 width = 2;
199 active.gradient = { 199 active.gradient = {
200 from = "hsla(195 100% 60% 0.9)"; 200 from = "hsla(195 100% 60% 0.75)";
201 to = "hsla(155 100% 50% 0.9)"; 201 to = "hsla(155 100% 50% 0.75)";
202 angle = 29; 202 angle = 29;
203 relative-to = "workspace-view"; 203 relative-to = "workspace-view";
204 }; 204 };
@@ -250,7 +250,6 @@ in {
250 allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; }; 250 allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; };
251 in allCorners 4.; 251 in allCorners 4.;
252 clip-to-geometry = true; 252 clip-to-geometry = true;
253 open-focused = true;
254 } 253 }
255 { 254 {
256 matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ]; 255 matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ];
@@ -263,14 +262,22 @@ in {
263 { 262 {
264 matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ]; 263 matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ];
265 excludes = [ 264 excludes = [
266 { title = "^Unlock Database"; } 265 { title = "^Unlock Database.*"; }
267 { title = "^Access Request"; } 266 { title = "^Access Request.*"; }
268 { title = "^Passkey credentials"; } 267 { title = "^Passkey credentials.*"; }
269 ]; 268 ];
270 open-on-workspace = "kpxc"; 269 open-on-workspace = "kpxc";
271 open-focused = false; 270 open-focused = false;
272 } 271 }
273 { 272 {
273 matches = [
274 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Unlock Database.*"; }
275 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Access Request.*"; }
276 { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Passkey credentials.*"; }
277 ];
278 open-focused = true;
279 }
280 {
274 matches = [ { app-id = "^kitty-scratch$"; } ]; 281 matches = [ { app-id = "^kitty-scratch$"; } ];
275 open-on-workspace = "term"; 282 open-on-workspace = "term";
276 } 283 }
@@ -300,6 +307,13 @@ in {
300 { 307 {
301 matches = [ { app-id = "^mpv$"; } ]; 308 matches = [ { app-id = "^mpv$"; } ];
302 open-on-workspace = "vid"; 309 open-on-workspace = "vid";
310 default-column-width.proportion = 1.;
311 }
312 {
313 matches = [ { app-id = "^kitty-play$"; } ];
314 open-on-workspace = "vid";
315 default-column-width.proportion = 1. / 3.;
316 open-focused = false;
303 } 317 }
304 # { 318 # {
305 # matches = [ 319 # matches = [
@@ -326,6 +340,13 @@ in {
326 socat STDIO UNIX-CONNECT:"$XDG_RUNTIME_DIR"/yt-dlp.sock <<<$'{ "urls": ["'"$(wl-paste)"$'"] }' 340 socat STDIO UNIX-CONNECT:"$XDG_RUNTIME_DIR"/yt-dlp.sock <<<$'{ "urls": ["'"$(wl-paste)"$'"] }'
327 ''; 341 '';
328 })); 342 }));
343 "Mod+Alt+L".action = spawn (lib.getExe (pkgs.writeShellApplication {
344 name = "queue-yt-dlp";
345 runtimeInputs = with pkgs; [ wl-clipboard-rs config.programs.kitty.package ];
346 text = ''
347 exec -- kitty --app-id kitty-play --directory "$HOME"/media mpv "$(wl-paste)"
348 '';
349 }));
329 350
330 "Mod+U".action = spawn (lib.getExe (pkgs.writeShellApplication { 351 "Mod+U".action = spawn (lib.getExe (pkgs.writeShellApplication {
331 name = "qalc-fuzzel"; 352 name = "qalc-fuzzel";