diff options
Diffstat (limited to 'accounts/gkleen@sif/niri/default.nix')
-rw-r--r-- | accounts/gkleen@sif/niri/default.nix | 9 |
1 files changed, 3 insertions, 6 deletions
diff --git a/accounts/gkleen@sif/niri/default.nix b/accounts/gkleen@sif/niri/default.nix index 216a98ea..0e25fc95 100644 --- a/accounts/gkleen@sif/niri/default.nix +++ b/accounts/gkleen@sif/niri/default.nix | |||
@@ -273,8 +273,6 @@ in { | |||
273 | workspaces = list() | 273 | workspaces = list() |
274 | 274 | ||
275 | def focus_workspace(output, workspace): | 275 | def focus_workspace(output, workspace): |
276 | global workspace_history, history_lock | ||
277 | |||
278 | with history_lock: | 276 | with history_lock: |
279 | workspace_history[output] = [workspace] + [ws for ws in workspace_history[output] if ws != workspace] # noqa: E501 | 277 | workspace_history[output] = [workspace] + [ws for ws in workspace_history[output] if ws != workspace] # noqa: E501 |
280 | print(json.dumps(workspace_history), file=sys.stderr) | 278 | print(json.dumps(workspace_history), file=sys.stderr) |
@@ -299,8 +297,6 @@ in { | |||
299 | 297 | ||
300 | class RequestHandler(StreamRequestHandler): | 298 | class RequestHandler(StreamRequestHandler): |
301 | def handle(self): | 299 | def handle(self): |
302 | global workspace_history, history_lock | ||
303 | |||
304 | with detaching(TextIOWrapper(self.wfile, encoding='utf-8', write_through=True)) as out: # noqa: E501 | 300 | with detaching(TextIOWrapper(self.wfile, encoding='utf-8', write_through=True)) as out: # noqa: E501 |
305 | with history_lock: | 301 | with history_lock: |
306 | json.dump(workspace_history, out) | 302 | json.dump(workspace_history, out) |
@@ -455,8 +451,8 @@ in { | |||
455 | (plain "layout" [ | 451 | (plain "layout" [ |
456 | (leaf "gaps" 8) | 452 | (leaf "gaps" 8) |
457 | (plain "struts" [ | 453 | (plain "struts" [ |
458 | (leaf "left" 0) | 454 | (leaf "left" 26) |
459 | (leaf "right" 0) | 455 | (leaf "right" 26) |
460 | (leaf "top" 0) | 456 | (leaf "top" 0) |
461 | (leaf "bottom" 0) | 457 | (leaf "bottom" 0) |
462 | ]) | 458 | ]) |
@@ -609,6 +605,7 @@ in { | |||
609 | (plain "window-rule" [ | 605 | (plain "window-rule" [ |
610 | (leaf "match" { app-id = "^org\\.pwmt\\.zathura$"; }) | 606 | (leaf "match" { app-id = "^org\\.pwmt\\.zathura$"; }) |
611 | (leaf "match" { app-id = "^evince$"; }) | 607 | (leaf "match" { app-id = "^evince$"; }) |
608 | (leaf "match" { app-id = "^org\\.gnome\\.Papers$"; }) | ||
612 | (leaf "default-column-display" "tabbed") | 609 | (leaf "default-column-display" "tabbed") |
613 | ]) | 610 | ]) |
614 | 611 | ||