summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/niri/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/niri/default.nix')
-rw-r--r--accounts/gkleen@sif/niri/default.nix273
1 files changed, 240 insertions, 33 deletions
diff --git a/accounts/gkleen@sif/niri/default.nix b/accounts/gkleen@sif/niri/default.nix
index 0c4a58e5..7e187c84 100644
--- a/accounts/gkleen@sif/niri/default.nix
+++ b/accounts/gkleen@sif/niri/default.nix
@@ -2,11 +2,10 @@
2let 2let
3 niri = config.programs.niri.package; 3 niri = config.programs.niri.package;
4 terminal = lib.getExe config.programs.kitty.package; 4 terminal = lib.getExe config.programs.kitty.package;
5 lightctl = lib.getExe' config.services.avizo.package "lightctl";
6 volumectl = lib.getExe' config.services.avizo.package "volumectl";
7 makoctl = lib.getExe' config.services.mako.package "makoctl"; 5 makoctl = lib.getExe' config.services.mako.package "makoctl";
8 loginctl = lib.getExe' hostConfig.systemd.package "loginctl"; 6 loginctl = lib.getExe' hostConfig.systemd.package "loginctl";
9 systemctl = lib.getExe' hostConfig.systemd.package "systemctl"; 7 systemctl = lib.getExe' hostConfig.systemd.package "systemctl";
8 swayosd-client = lib.getExe' config.services.swayosd.package "swayosd-client";
10 9
11 focus_or_spawn = pkgs.writeShellApplication { 10 focus_or_spawn = pkgs.writeShellApplication {
12 name = "focus-or-spawn"; 11 name = "focus-or-spawn";
@@ -19,17 +18,21 @@ let
19 18
20 workspaces_json="$(niri msg -j workspaces)" 19 workspaces_json="$(niri msg -j workspaces)"
21 workspace_output="$(jq -r --arg workspace_name "$workspace_name" '.[] | select(.name == $workspace_name) | .output' <<<"$workspaces_json")" 20 workspace_output="$(jq -r --arg workspace_name "$workspace_name" '.[] | select(.name == $workspace_name) | .output' <<<"$workspaces_json")"
22 active_workspace="$(jq -r --arg workspace_output "$workspace_output" '.[] | select(.output == $workspace_output and .is_active) | .id' <<<"$workspaces_json")" 21 # active_workspace="$(jq -r --arg workspace_output "$workspace_output" '.[] | select(.output == $workspace_output and .is_active) | .id' <<<"$workspaces_json")"
23 active_output="$(jq -r '.[] | select(.is_focused) | .output' <<<"$workspaces_json")" 22 active_output="$(jq -r '.[] | select(.is_focused) | .output' <<<"$workspaces_json")"
24 if [[ $workspace_output != "$active_output" ]]; then 23 if [[ $workspace_output != "$active_output" ]]; then
25 niri msg action move-workspace-to-monitor --output "$active_output" "$workspace_name" 24 niri msg action move-workspace-to-monitor --reference "$workspace_name" "$active_output"
26 socat STDIO "$NIRI_SOCKET" <<<'{"Action":{"FocusWorkspace":{"reference":{"Id":'"''${active_workspace}"'}}}}' 25 # socat STDIO "$NIRI_SOCKET" <<<'{"Action":{"FocusWorkspace":{"reference":{"Id":'"''${active_workspace}"'}}}}'
27 niri msg action move-workspace-to-index --index 1 "$workspace_name" 26 # niri msg action move-workspace-to-index --reference "$workspace_name" 1
28 fi 27 fi
29 28
30 while IFS=$'\n' read -r window_json; do 29 while IFS=$'\n' read -r window_json; do
31 if [[ -n $(jq -c "$window_select" <<<"$window_json") ]]; then 30 if [[ -n $(jq -c "$window_select" <<<"$window_json") ]]; then
32 niri msg action focus-window --id "$(jq -r '.id' <<<"$window_json")" 31 if jq -e '.is_focused' <<<"$window_json" >/dev/null; then
32 niri msg action focus-workspace-previous
33 else
34 niri msg action focus-window --id "$(jq -r '.id' <<<"$window_json")"
35 fi
33 exit 0 36 exit 0
34 fi 37 fi
35 done < <(niri msg -j windows | jq -c '.[]') 38 done < <(niri msg -j windows | jq -c '.[]')
@@ -75,7 +78,7 @@ let
75 jq --arg active_workspace "$active_workspace" -c "$action" <<<"$workspace_json" | tee /dev/stderr | socat STDIO "$NIRI_SOCKET" 78 jq --arg active_workspace "$active_workspace" -c "$action" <<<"$workspace_json" | tee /dev/stderr | socat STDIO "$NIRI_SOCKET"
76 ''; 79 '';
77 }; 80 };
78 with-adjacent-workspace-action = config.lib.niri.actions.spawn (lib.getExe with_adjacent_workspace) "^pwctl|kpxc|bmgr|edit|term$"; 81 with-adjacent-workspace-action = config.lib.niri.actions.spawn (lib.getExe with_adjacent_workspace) "^pwctl|eff|kpxc|bmgr|edit|term$";
79 focus-adjacent-workspace = direction: with-adjacent-workspace-action direction ''{"Action":{"FocusWorkspace":{"reference":{"Id": .id}}}}''; 82 focus-adjacent-workspace = direction: with-adjacent-workspace-action direction ''{"Action":{"FocusWorkspace":{"reference":{"Id": .id}}}}'';
80 move-column-to-adjacent-workspace = direction: with-adjacent-workspace-action direction ''{"Action":{"MoveColumnToWorkspace":{"reference":{"Id": .id}}}}''; 83 move-column-to-adjacent-workspace = direction: with-adjacent-workspace-action direction ''{"Action":{"MoveColumnToWorkspace":{"reference":{"Id": .id}}}}'';
81 84
@@ -90,7 +93,8 @@ let
90 active_output="$(jq -r '.[] | select(.is_focused) | .output' <<<"$workspaces_json")" 93 active_output="$(jq -r '.[] | select(.is_focused) | .output' <<<"$workspaces_json")"
91 active_workspace="$(jq -r '.[] | select(.is_focused) | .id' <<<"$workspaces_json")" 94 active_workspace="$(jq -r '.[] | select(.is_focused) | .id' <<<"$workspaces_json")"
92 95
93 workspace_json="$(jq -c --arg active_output "$active_output" 'map(select(.output == $active_output and .name == null)) | sort_by(.idx) | .[0]' <<<"$workspaces_json")" 96 history_json="$(socat STDIO UNIX-CONNECT:"$XDG_RUNTIME_DIR"/niri-workspace-history.sock)"
97 workspace_json="$(jq -c --arg active_output "$active_output" --argjson history "$history_json" 'map(select(.output == $active_output and .name == null)) | map({"value": ., "history_idx": ((. as $workspace | ($history[$active_output] | index($workspace | .id))) as $active_idx | if $active_idx then $active_idx else ($history[$active_output] | length) + 1 end)}) | sort_by(.history_idx, .value.idx) | map(.value) | .[0]' <<<"$workspaces_json")"
94 [[ -n $workspace_json && $workspace_json != null ]] || exit 0 98 [[ -n $workspace_json && $workspace_json != null ]] || exit 0
95 jq --arg active_workspace "$active_workspace" -c "$action" <<<"$workspace_json" | tee /dev/stderr | socat STDIO "$NIRI_SOCKET" 99 jq --arg active_workspace "$active_workspace" -c "$action" <<<"$workspace_json" | tee /dev/stderr | socat STDIO "$NIRI_SOCKET"
96 ''; 100 '';
@@ -98,7 +102,7 @@ let
98 with-unnamed-workspace-action = config.lib.niri.actions.spawn (lib.getExe with_unnamed_workspace); 102 with-unnamed-workspace-action = config.lib.niri.actions.spawn (lib.getExe with_unnamed_workspace);
99 103
100 with_select_window = pkgs.writeShellApplication { 104 with_select_window = pkgs.writeShellApplication {
101 name = "with-unnamed-workspace"; 105 name = "with-select-window";
102 runtimeInputs = [ niri pkgs.gojq pkgs.socat config.programs.fuzzel.package pkgs.gawk ]; 106 runtimeInputs = [ niri pkgs.gojq pkgs.socat config.programs.fuzzel.package pkgs.gawk ];
103 text = '' 107 text = ''
104 window_select="$1" 108 window_select="$1"
@@ -108,9 +112,9 @@ let
108 112
109 windows_json="$(niri msg -j windows)" 113 windows_json="$(niri msg -j windows)"
110 active_workspace="$(jq -r '.[] | select(.is_focused) | .workspace_id' <<<"$windows_json")" 114 active_workspace="$(jq -r '.[] | select(.is_focused) | .workspace_id' <<<"$windows_json")"
111 window="$(gojq -r --arg active_workspace "$active_workspace" '.[] | select('"$window_select"') | "\(.title)\t\(.id)"' <<<"$windows_json" | fuzzel --log-level=warning --dmenu)" 115 window_ix="$(gojq -r --arg active_workspace "$active_workspace" '.[] | select('"$window_select"') | "\(.title)\u0000icon\u001f\(.app_id)"' <<<"$windows_json" | fuzzel --log-level=warning --dmenu --index)"
112 window_id="$(awk -F $'\t' '{print $2}' <<<"$window")" 116 # shellcheck disable=SC2016
113 window_json="$(jq -r --arg window_id "$window_id" '.[] | select(.id == ($window_id | tonumber))' <<<"$windows_json")" 117 window_json="$(gojq -rc --arg active_workspace "$active_workspace" --arg window_ix "$window_ix" 'map(select('"$window_select"')) | .[($window_ix | tonumber)]' <<<"$windows_json")"
114 118
115 [[ -z "$window_json" ]] && exit 1 119 [[ -z "$window_json" ]] && exit 1
116 120
@@ -122,6 +126,7 @@ in {
122 imports = [ 126 imports = [
123 ./waybar.nix 127 ./waybar.nix
124 ./mako.nix 128 ./mako.nix
129 ./swayosd.nix
125 ]; 130 ];
126 131
127 config = { 132 config = {
@@ -156,6 +161,113 @@ in {
156 ]; 161 ];
157 }; 162 };
158 163
164 systemd.user.sockets.niri-workspace-history = {
165 Socket = {
166 ListenStream = "%t/niri-workspace-history.sock";
167 SocketMode = "0600";
168 };
169 };
170 systemd.user.services.niri-workspace-history = {
171 Unit = {
172 BindsTo = [ "niri.service" ];
173 After = [ "niri.service" ];
174 };
175 Install = {
176 WantedBy = [ "niri.service" ];
177 };
178 Service = {
179 Type = "simple";
180 Sockets = [ "niri-workspace-history.socket" ];
181 ExecStart = pkgs.writers.writePython3 "niri-workspace-history" {} ''
182 import os
183 import socket
184 import json
185 import sys
186 from collections import defaultdict
187 from threading import Thread, Lock
188 from socketserver import StreamRequestHandler, ThreadingTCPServer
189 from contextlib import contextmanager
190 from io import TextIOWrapper
191
192
193 @contextmanager
194 def detaching(thing):
195 try:
196 yield thing
197 finally:
198 thing.detach()
199
200
201 workspace_history = defaultdict(list)
202 history_lock = Lock()
203
204
205 def monitor_niri():
206 workspaces = list()
207
208 def focus_workspace(output, workspace):
209 global workspace_history, history_lock
210
211 with history_lock:
212 workspace_history[output] = [workspace] + [ws for ws in workspace_history[output] if ws != workspace] # noqa: E501
213 print(json.dumps(workspace_history), file=sys.stderr)
214
215 sock = socket.socket(socket.AF_UNIX, socket.SOCK_STREAM)
216 sock.connect(os.environ["NIRI_SOCKET"])
217 sock.send(b"\"EventStream\"\n")
218 for line in sock.makefile(buffering=1, encoding='utf-8'):
219 if line_json := json.loads(line):
220 if "WorkspacesChanged" in line_json:
221 workspaces = line_json["WorkspacesChanged"]["workspaces"]
222 for ws in workspaces:
223 if ws["is_focused"]:
224 focus_workspace(ws["output"], ws["id"])
225 if "WorkspaceActivated" in line_json:
226 for ws in workspaces:
227 if ws["id"] != line_json["WorkspaceActivated"]["id"]:
228 continue
229 focus_workspace(ws["output"], ws["id"])
230 break
231
232
233 class RequestHandler(StreamRequestHandler):
234 def handle(self):
235 global workspace_history, history_lock
236
237 with detaching(TextIOWrapper(self.wfile, encoding='utf-8', write_through=True)) as out: # noqa: E501
238 with history_lock:
239 json.dump(workspace_history, out)
240
241
242 class Server(ThreadingTCPServer):
243 def __init__(self):
244 ThreadingTCPServer.__init__(self, ("", 8000), RequestHandler, bind_and_activate=False) # noqa: E501
245 self.socket = socket.fromfd(3, self.address_family, self.socket_type)
246
247
248 def run_server():
249 with Server() as server:
250 server.serve_forever()
251
252
253 niri = Thread(target=monitor_niri)
254 niri.daemon = True
255 niri.start()
256
257 server_thread = Thread(target=run_server)
258 server_thread.daemon = True
259 server_thread.start()
260
261 while True:
262 server_thread.join(timeout=0.5)
263 niri.join(timeout=0.5)
264
265 if not (niri.is_alive() and server_thread.is_alive()):
266 break
267 '';
268 };
269 };
270
159 programs.niri.settings = { 271 programs.niri.settings = {
160 prefer-no-csd = true; 272 prefer-no-csd = true;
161 screenshot-path = "${config.home.homeDirectory}/screenshots"; 273 screenshot-path = "${config.home.homeDirectory}/screenshots";
@@ -163,10 +275,15 @@ in {
163 hotkey-overlay.skip-at-startup = true; 275 hotkey-overlay.skip-at-startup = true;
164 276
165 input = { 277 input = {
166 keyboard.xkb = { 278 keyboard = {
167 layout = "us,us"; 279 repeat-delay = 300;
168 variant = "dvp,"; 280 repeat-rate = 50;
169 options = "compose:caps,grp:win_space_toggle"; 281
282 xkb = {
283 layout = "us,us";
284 variant = "dvp,";
285 options = "compose:caps,grp:win_space_toggle";
286 };
170 }; 287 };
171 288
172 workspace-auto-back-and-forth = true; 289 workspace-auto-back-and-forth = true;
@@ -183,13 +300,28 @@ in {
183 scale = 1.5; 300 scale = 1.5;
184 position = { x = 2560; y = 0; }; 301 position = { x = 2560; y = 0; };
185 }; 302 };
303 "HP Inc. HP 727pu CN4417143K" = {
304 mode = { width = 2560; height = 1440; refresh = 119.998; };
305 scale = 1;
306 position = { x = 2560; y = 0; };
307 variable-refresh-rate = "on-demand";
308 };
186 }; 309 };
187 310
188 environment = { 311 environment = {
189 NIXOS_OZONE_WL = "1"; 312 NIXOS_OZONE_WL = "1";
190 QT_QPA_PLATFORM = "wayland"; 313 QT_QPA_PLATFORM = "wayland";
314 QT_WAYLAND_DISABLE_WINDOWDECORATION = "1";
191 GDK_BACKEND = "wayland"; 315 GDK_BACKEND = "wayland";
192 SDL_VIDEODRIVER = "wayland"; 316 SDL_VIDEODRIVER = "wayland";
317 DISPLAY = ":0";
318 };
319
320 debug.render-drm-device = "/dev/dri/by-path/pci-0000:00:02.0-render";
321
322 animations = {
323 slowdown = 0.5;
324 workspace-switch = null;
193 }; 325 };
194 326
195 layout = { 327 layout = {
@@ -231,34 +363,56 @@ in {
231 363
232 cursor.hide-when-typing = true; 364 cursor.hide-when-typing = true;
233 365
366 input = {
367 touchpad.enable = false;
368 trackball = {
369 scroll-method = "on-button-down";
370 scroll-button = 278;
371 };
372 };
373
234 workspaces = { 374 workspaces = {
235 "001" = { name = "pwctl"; open-on-output = "eDP-1"; }; 375 "001" = { name = "pwctl"; open-on-output = "eDP-1"; };
236 "002" = { name = "kpxc"; open-on-output = "eDP-1"; }; 376 "002" = { name = "kpxc"; open-on-output = "eDP-1"; };
237 "003" = { name = "bmgr"; open-on-output = "eDP-1"; }; 377 "003" = { name = "bmgr"; open-on-output = "eDP-1"; };
238 "004" = { name = "term"; open-on-output = "eDP-1"; }; 378 "004" = { name = "term"; open-on-output = "eDP-1"; };
239 "005" = { name = "edit"; open-on-output = "eDP-1"; }; 379 "005" = { name = "edit"; open-on-output = "eDP-1"; };
380 "006" = { name = "eff"; open-on-output = "eDP-1"; };
240 "101".name = "comm"; 381 "101".name = "comm";
241 "102".name = "web"; 382 "102".name = "web";
242 # "104".name = "read"; 383 # "104".name = "read";
243 # "105".name = "mon"; 384 # "105".name = "mon";
244 "110".name = "vid"; 385 "110".name = "vid";
386 "120".name = "bmr";
245 }; 387 };
246 388
247 window-rules = [ 389 window-rules = [
248 # { 390 {
249 # geometry-corner-radius = 391 matches = [ { is-floating = true; } ];
250 # let 392 geometry-corner-radius =
251 # allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; }; 393 let
252 # in allCorners 4.; 394 allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; };
253 # clip-to-geometry = true; 395 in allCorners 8.;
254 # } 396 clip-to-geometry = true;
397 }
255 { 398 {
256 matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ]; 399 matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ];
257 open-on-workspace = "pwctl"; 400 open-on-workspace = "pwctl";
401 open-maximized = true;
402 }
403 {
404 matches = [ { app-id = "^com\.github\.wwmm\.easyeffects$"; } ];
405 open-on-workspace = "eff";
406 open-maximized = true;
258 } 407 }
259 { 408 {
260 matches = [ { app-id = "^\.blueman-manager-wrapped$"; } ]; 409 matches = [ { app-id = "^\.blueman-manager-wrapped$"; } ];
261 open-on-workspace = "bmgr"; 410 open-on-workspace = "bmgr";
411 open-maximized = true;
412 }
413 {
414 matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ];
415 block-out-from = "screencast";
262 } 416 }
263 { 417 {
264 matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ]; 418 matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ];
@@ -268,6 +422,7 @@ in {
268 { title = ".*Passkey credentials$"; } 422 { title = ".*Passkey credentials$"; }
269 ]; 423 ];
270 open-on-workspace = "kpxc"; 424 open-on-workspace = "kpxc";
425 open-maximized = true;
271 open-focused = false; 426 open-focused = false;
272 } 427 }
273 { 428 {
@@ -277,25 +432,45 @@ in {
277 { app-id = "^org\.keepassxc\.KeePassXC$"; title = ".*Passkey credentials$"; } 432 { app-id = "^org\.keepassxc\.KeePassXC$"; title = ".*Passkey credentials$"; }
278 ]; 433 ];
279 open-focused = true; 434 open-focused = true;
435 open-floating = true;
280 } 436 }
281 { 437 {
282 matches = [ { app-id = "^kitty-scratch$"; } ]; 438 matches = [ { app-id = "^kitty-scratch$"; } ];
283 open-on-workspace = "term"; 439 open-on-workspace = "term";
440 open-maximized = true;
284 } 441 }
285 { 442 {
286 matches = [ { title = "^scratch$"; app-id = "^emacs$"; } ]; 443 matches = [ { title = "^scratch$"; app-id = "^emacs$"; } ];
287 open-on-workspace = "edit"; 444 open-on-workspace = "edit";
445 open-maximized = true;
446 }
447 {
448 matches = [
449 { app-id = "^emacs$"; }
450 { app-id = "^firefox$"; }
451 ];
452 default-column-width.proportion = 2. / 3.;
453 }
454 {
455 matches = [
456 { app-id = "^kitty$"; }
457 { app-id = "^kitty-play$"; }
458 ];
459 default-column-width.proportion = 1. / 3.;
288 } 460 }
289 { 461 {
290 matches = [ 462 matches = [
291 { app-id = "^thunderbird$"; } 463 { app-id = "^thunderbird$"; }
292 { app-id = "^Element$"; } 464 { app-id = "^Element$"; }
465 { app-id = "^Rainbow$"; }
293 ]; 466 ];
294 open-on-workspace = "comm"; 467 open-on-workspace = "comm";
295 } 468 }
296 { 469 {
297 matches = [ { app-id = "^firefox$"; } ]; 470 matches = [ { app-id = "^firefox$"; } ];
298 open-on-workspace = "web"; 471 open-on-workspace = "web";
472 open-maximized = true;
473 variable-refresh-rate = true;
299 } 474 }
300 # { 475 # {
301 # matches = [ 476 # matches = [
@@ -309,11 +484,11 @@ in {
309 matches = [ { app-id = "^mpv$"; } ]; 484 matches = [ { app-id = "^mpv$"; } ];
310 open-on-workspace = "vid"; 485 open-on-workspace = "vid";
311 default-column-width.proportion = 1.; 486 default-column-width.proportion = 1.;
487 variable-refresh-rate = true;
312 } 488 }
313 { 489 {
314 matches = [ { app-id = "^kitty-play$"; } ]; 490 matches = [ { app-id = "^kitty-play$"; } ];
315 open-on-workspace = "vid"; 491 open-on-workspace = "vid";
316 default-column-width.proportion = 1. / 3.;
317 open-focused = false; 492 open-focused = false;
318 } 493 }
319 # { 494 # {
@@ -323,6 +498,31 @@ in {
323 # ]; 498 # ];
324 # open-on-workspace = "mon"; 499 # open-on-workspace = "mon";
325 # } 500 # }
501 {
502 matches = [ { app-id = "^pdfpc$"; } ];
503 default-column-width.proportion = 1.;
504 }
505 {
506 matches = [ { app-id = "^pdfpc$"; title = "^pdfpc - presentation"; } ];
507 open-on-workspace = "bmr";
508 open-fullscreen = true;
509 }
510 {
511 matches = [
512 { app-id = "^Gimp-"; title = "^Quit GIMP$"; }
513 { app-id = "^org\.kde\.polkit-kde-authentication-agent-1$"; }
514 { app-id = "^xdg-desktop-portal-gtk$"; }
515 ];
516 open-floating = true;
517 }
518 ];
519 layer-rules = [
520 { matches = [
521 { namespace = "^notifications$"; }
522 { namespace = "^waybar$"; }
523 ];
524 block-out-from = "screencast";
525 }
326 ]; 526 ];
327 527
328 binds = with config.lib.niri.actions; { 528 binds = with config.lib.niri.actions; {
@@ -373,12 +573,14 @@ in {
373 fi 573 fi
374 [[ -n "$QALC_RES" ]] || exit 1 574 [[ -n "$QALC_RES" ]] || exit 1
375 EXISTING=false 575 EXISTING=false
376 set +e 576 set +o pipefail
377 grep -Fxrl "$QALC_RES" "$RESULTS_DIR" | xargs -r touch 577 grep -Fxrl "$QALC_RES" "$RESULTS_DIR" | xargs -r touch
378 [[ ''${PIPESTATUS[0]} -eq 0 ]] && EXISTING=true 578 [[ ''${PIPESTATUS[0]} -eq 0 ]] && EXISTING=true
379 set -e 579 set -o pipefail
380 if [[ $QALC_RET -eq 0 ]] && ! $EXISTING; then 580 if [[ $QALC_RET -eq 0 ]] && ! $EXISTING; then
581 set +o pipefail
381 RES_FILE="$RESULTS_DIR"/$(date -uIs).$(tr -Cd 'a-zA-Z0-9' </dev/random | head -c 10) 582 RES_FILE="$RESULTS_DIR"/$(date -uIs).$(tr -Cd 'a-zA-Z0-9' </dev/random | head -c 10)
583 set -o pipefail
382 cat >"$RES_FILE" <<<"$QALC_RES" 584 cat >"$RES_FILE" <<<"$QALC_RES"
383 fi 585 fi
384 [[ "$QALC_RES" =~ .*\ =\ (.*) ]] && QALC_RES="''${BASH_REMATCH[1]}" 586 [[ "$QALC_RES" =~ .*\ =\ (.*) ]] && QALC_RES="''${BASH_REMATCH[1]}"
@@ -494,29 +696,33 @@ in {
494 action = spawn systemctl "hibernate"; 696 action = spawn systemctl "hibernate";
495 allow-when-locked = true; 697 allow-when-locked = true;
496 }; 698 };
699 "Mod+Shift+P" = {
700 action = spawn (lib.getExe pkgs.playerctl) "-a" "pause";
701 allow-when-locked = true;
702 };
497 703
498 "XF86MonBrightnessUp" = { 704 "XF86MonBrightnessUp" = {
499 action = spawn lightctl "-d" "-e4" "-n1" "up"; 705 action = spawn swayosd-client "--brightness" "raise";
500 allow-when-locked = true; 706 allow-when-locked = true;
501 }; 707 };
502 "XF86MonBrightnessDown" = { 708 "XF86MonBrightnessDown" = {
503 action = spawn lightctl "-d" "-e4" "-n1" "down"; 709 action = spawn swayosd-client "--brightness" "lower";
504 allow-when-locked = true; 710 allow-when-locked = true;
505 }; 711 };
506 "XF86AudioRaiseVolume" = { 712 "XF86AudioRaiseVolume" = {
507 action = spawn volumectl "-d" "-u" "up"; 713 action = spawn swayosd-client "--output-volume" "raise";
508 allow-when-locked = true; 714 allow-when-locked = true;
509 }; 715 };
510 "XF86AudioLowerVolume" = { 716 "XF86AudioLowerVolume" = {
511 action = spawn volumectl "-d" "-u" "down"; 717 action = spawn swayosd-client "--output-volume" "lower";
512 allow-when-locked = true; 718 allow-when-locked = true;
513 }; 719 };
514 "XF86AudioMute" = { 720 "XF86AudioMute" = {
515 action = spawn volumectl "-d" "toggle-mute"; 721 action = spawn swayosd-client "--output-volume" "mute-toggle";
516 allow-when-locked = true; 722 allow-when-locked = true;
517 }; 723 };
518 "XF86AudioMicMute" = { 724 "XF86AudioMicMute" = {
519 action = spawn volumectl "-d" "-m" "toggle-mute"; 725 action = spawn swayosd-client "--input-volume" "mute-toggle";
520 allow-when-locked = true; 726 allow-when-locked = true;
521 }; 727 };
522 728
@@ -526,6 +732,7 @@ in {
526 "Mod+Comma".action = spawn makoctl "restore"; 732 "Mod+Comma".action = spawn makoctl "restore";
527 733
528 "Mod+Control+A".action = focus-or-spawn-action-app_id "com.saivert.pwvucontrol" "pwctl" "pwvucontrol"; 734 "Mod+Control+A".action = focus-or-spawn-action-app_id "com.saivert.pwvucontrol" "pwctl" "pwvucontrol";
735 "Mod+Control+O".action = focus-or-spawn-action-app_id "com.github.wwmm.easyeffects" "eff" "easyeffects";
529 "Mod+Control+P".action = focus-or-spawn-action-app_id "org.keepassxc.KeePassXC" "kpxc" "keepassxc"; 736 "Mod+Control+P".action = focus-or-spawn-action-app_id "org.keepassxc.KeePassXC" "kpxc" "keepassxc";
530 "Mod+Control+B".action = focus-or-spawn-action-app_id ".blueman-manager-wrapped" "bmgr" "blueman-manager"; 737 "Mod+Control+B".action = focus-or-spawn-action-app_id ".blueman-manager-wrapped" "bmgr" "blueman-manager";
531 "Mod+Control+Return".action = focus-or-spawn-action-app_id "kitty-scratch" "term" "kitty" "--app-id" "kitty-scratch"; 738 "Mod+Control+Return".action = focus-or-spawn-action-app_id "kitty-scratch" "term" "kitty" "--app-id" "kitty-scratch";