diff options
Diffstat (limited to 'accounts/gkleen@sif/niri/default.nix')
-rw-r--r-- | accounts/gkleen@sif/niri/default.nix | 743 |
1 files changed, 743 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/niri/default.nix b/accounts/gkleen@sif/niri/default.nix new file mode 100644 index 00000000..7e187c84 --- /dev/null +++ b/accounts/gkleen@sif/niri/default.nix | |||
@@ -0,0 +1,743 @@ | |||
1 | { config, hostConfig, pkgs, lib, ... }: | ||
2 | let | ||
3 | niri = config.programs.niri.package; | ||
4 | terminal = lib.getExe config.programs.kitty.package; | ||
5 | makoctl = lib.getExe' config.services.mako.package "makoctl"; | ||
6 | loginctl = lib.getExe' hostConfig.systemd.package "loginctl"; | ||
7 | systemctl = lib.getExe' hostConfig.systemd.package "systemctl"; | ||
8 | swayosd-client = lib.getExe' config.services.swayosd.package "swayosd-client"; | ||
9 | |||
10 | focus_or_spawn = pkgs.writeShellApplication { | ||
11 | name = "focus-or-spawn"; | ||
12 | runtimeInputs = [ niri pkgs.gojq pkgs.gnugrep pkgs.socat ]; | ||
13 | text = '' | ||
14 | window_select="$1" | ||
15 | shift | ||
16 | workspace_name="$1" | ||
17 | shift | ||
18 | |||
19 | workspaces_json="$(niri msg -j workspaces)" | ||
20 | workspace_output="$(jq -r --arg workspace_name "$workspace_name" '.[] | select(.name == $workspace_name) | .output' <<<"$workspaces_json")" | ||
21 | # active_workspace="$(jq -r --arg workspace_output "$workspace_output" '.[] | select(.output == $workspace_output and .is_active) | .id' <<<"$workspaces_json")" | ||
22 | active_output="$(jq -r '.[] | select(.is_focused) | .output' <<<"$workspaces_json")" | ||
23 | if [[ $workspace_output != "$active_output" ]]; then | ||
24 | niri msg action move-workspace-to-monitor --reference "$workspace_name" "$active_output" | ||
25 | # socat STDIO "$NIRI_SOCKET" <<<'{"Action":{"FocusWorkspace":{"reference":{"Id":'"''${active_workspace}"'}}}}' | ||
26 | # niri msg action move-workspace-to-index --reference "$workspace_name" 1 | ||
27 | fi | ||
28 | |||
29 | while IFS=$'\n' read -r window_json; do | ||
30 | if [[ -n $(jq -c "$window_select" <<<"$window_json") ]]; then | ||
31 | if jq -e '.is_focused' <<<"$window_json" >/dev/null; then | ||
32 | niri msg action focus-workspace-previous | ||
33 | else | ||
34 | niri msg action focus-window --id "$(jq -r '.id' <<<"$window_json")" | ||
35 | fi | ||
36 | exit 0 | ||
37 | fi | ||
38 | done < <(niri msg -j windows | jq -c '.[]') | ||
39 | |||
40 | exec "$@" | ||
41 | ''; | ||
42 | }; | ||
43 | focus-or-spawn-action = config.lib.niri.actions.spawn (lib.getExe focus_or_spawn); | ||
44 | focus-or-spawn-action-app_id = app_id: focus-or-spawn-action ''select(.app_id == "${app_id}")''; | ||
45 | |||
46 | with_adjacent_workspace = pkgs.writeShellApplication { | ||
47 | name = "with-adjacent-workspace"; | ||
48 | runtimeInputs = [ niri pkgs.gojq pkgs.socat ]; | ||
49 | text = '' | ||
50 | blacklist="$1" | ||
51 | shift | ||
52 | direction="$1" | ||
53 | shift | ||
54 | action="$1" | ||
55 | shift | ||
56 | |||
57 | workspaces_json="$(niri msg -j workspaces)" | ||
58 | active_workspace="$(jq -r '.[] | select(.is_focused) | .id' <<<"$workspaces_json")" | ||
59 | workspace_output="$(jq -r --arg active_workspace "$active_workspace" '.[] | select(.id == ($active_workspace | tonumber)) | .output' <<<"$workspaces_json")" | ||
60 | workspace_idx="$(jq -r '.[] | select(.is_focused) | .idx' <<<"$workspaces_json")" | ||
61 | |||
62 | jq_script='map(select(' | ||
63 | case "$direction" in | ||
64 | down) | ||
65 | # shellcheck disable=SC2016 | ||
66 | jq_script=''${jq_script}'.idx > ($workspace_idx | tonumber)';; | ||
67 | up) | ||
68 | # shellcheck disable=SC2016 | ||
69 | jq_script=''${jq_script}'.idx < ($workspace_idx | tonumber)';; | ||
70 | esac | ||
71 | # shellcheck disable=SC2016 | ||
72 | jq_script=''${jq_script}' and .output == $workspace_output and ((.name == null) or (.name | test($blacklist) | not)))) | sort_by(.idx)' | ||
73 | [[ $direction == "up" ]] && jq_script=''${jq_script}' | reverse' | ||
74 | jq_script=''${jq_script}' | .[0]' | ||
75 | |||
76 | workspace_json=$(jq -c --arg blacklist "$blacklist" --arg workspace_output "$workspace_output" --arg workspace_idx "$workspace_idx" "$jq_script" <<<"$workspaces_json") | ||
77 | [[ -n $workspace_json && $workspace_json != null ]] || exit 0 | ||
78 | jq --arg active_workspace "$active_workspace" -c "$action" <<<"$workspace_json" | tee /dev/stderr | socat STDIO "$NIRI_SOCKET" | ||
79 | ''; | ||
80 | }; | ||
81 | with-adjacent-workspace-action = config.lib.niri.actions.spawn (lib.getExe with_adjacent_workspace) "^pwctl|eff|kpxc|bmgr|edit|term$"; | ||
82 | focus-adjacent-workspace = direction: with-adjacent-workspace-action direction ''{"Action":{"FocusWorkspace":{"reference":{"Id": .id}}}}''; | ||
83 | move-column-to-adjacent-workspace = direction: with-adjacent-workspace-action direction ''{"Action":{"MoveColumnToWorkspace":{"reference":{"Id": .id}}}}''; | ||
84 | |||
85 | with_unnamed_workspace = pkgs.writeShellApplication { | ||
86 | name = "with-unnamed-workspace"; | ||
87 | runtimeInputs = [ niri pkgs.gojq pkgs.socat ]; | ||
88 | text = '' | ||
89 | action="$1" | ||
90 | shift | ||
91 | |||
92 | workspaces_json="$(niri msg -j workspaces)" | ||
93 | active_output="$(jq -r '.[] | select(.is_focused) | .output' <<<"$workspaces_json")" | ||
94 | active_workspace="$(jq -r '.[] | select(.is_focused) | .id' <<<"$workspaces_json")" | ||
95 | |||
96 | history_json="$(socat STDIO UNIX-CONNECT:"$XDG_RUNTIME_DIR"/niri-workspace-history.sock)" | ||
97 | workspace_json="$(jq -c --arg active_output "$active_output" --argjson history "$history_json" 'map(select(.output == $active_output and .name == null)) | map({"value": ., "history_idx": ((. as $workspace | ($history[$active_output] | index($workspace | .id))) as $active_idx | if $active_idx then $active_idx else ($history[$active_output] | length) + 1 end)}) | sort_by(.history_idx, .value.idx) | map(.value) | .[0]' <<<"$workspaces_json")" | ||
98 | [[ -n $workspace_json && $workspace_json != null ]] || exit 0 | ||
99 | jq --arg active_workspace "$active_workspace" -c "$action" <<<"$workspace_json" | tee /dev/stderr | socat STDIO "$NIRI_SOCKET" | ||
100 | ''; | ||
101 | }; | ||
102 | with-unnamed-workspace-action = config.lib.niri.actions.spawn (lib.getExe with_unnamed_workspace); | ||
103 | |||
104 | with_select_window = pkgs.writeShellApplication { | ||
105 | name = "with-select-window"; | ||
106 | runtimeInputs = [ niri pkgs.gojq pkgs.socat config.programs.fuzzel.package pkgs.gawk ]; | ||
107 | text = '' | ||
108 | window_select="$1" | ||
109 | shift | ||
110 | action="$1" | ||
111 | shift | ||
112 | |||
113 | windows_json="$(niri msg -j windows)" | ||
114 | active_workspace="$(jq -r '.[] | select(.is_focused) | .workspace_id' <<<"$windows_json")" | ||
115 | window_ix="$(gojq -r --arg active_workspace "$active_workspace" '.[] | select('"$window_select"') | "\(.title)\u0000icon\u001f\(.app_id)"' <<<"$windows_json" | fuzzel --log-level=warning --dmenu --index)" | ||
116 | # shellcheck disable=SC2016 | ||
117 | window_json="$(gojq -rc --arg active_workspace "$active_workspace" --arg window_ix "$window_ix" 'map(select('"$window_select"')) | .[($window_ix | tonumber)]' <<<"$windows_json")" | ||
118 | |||
119 | [[ -z "$window_json" ]] && exit 1 | ||
120 | |||
121 | jq -c "$action" <<<"$window_json" | socat STDIO "$NIRI_SOCKET" | ||
122 | ''; | ||
123 | }; | ||
124 | with-select-window-action = config.lib.niri.actions.spawn (lib.getExe with_select_window); | ||
125 | in { | ||
126 | imports = [ | ||
127 | ./waybar.nix | ||
128 | ./mako.nix | ||
129 | ./swayosd.nix | ||
130 | ]; | ||
131 | |||
132 | config = { | ||
133 | systemd.user.services.xwayland-satellite = { | ||
134 | Unit = { | ||
135 | BindsTo = [ "graphical-session.target" ]; | ||
136 | PartOf = [ "graphical-session.target" ]; | ||
137 | After = [ "graphical-session.target" ]; | ||
138 | Requisite = [ "graphical-session.target" ]; | ||
139 | }; | ||
140 | Service = { | ||
141 | Type = "notify"; | ||
142 | NotifyAccess = "all"; | ||
143 | Environment = [ "DISPLAY=:0" ]; | ||
144 | ExecStart = ''${lib.getExe pkgs.xwayland-satellite-unstable} ''${DISPLAY}''; | ||
145 | ExecStartPre = "${systemctl} --user import-environment DISPLAY"; | ||
146 | StandardOutput = "journal"; | ||
147 | }; | ||
148 | Install = { | ||
149 | WantedBy = [ "graphical-session.target" ]; | ||
150 | }; | ||
151 | }; | ||
152 | |||
153 | services.swayidle = { | ||
154 | events = [ | ||
155 | { event = "after-resume"; command = "${lib.getExe niri} msg action power-on-monitors"; } | ||
156 | ]; | ||
157 | timeouts = [ | ||
158 | { timeout = 300; | ||
159 | command = "${lib.getExe niri} msg action power-off-monitors"; | ||
160 | } | ||
161 | ]; | ||
162 | }; | ||
163 | |||
164 | systemd.user.sockets.niri-workspace-history = { | ||
165 | Socket = { | ||
166 | ListenStream = "%t/niri-workspace-history.sock"; | ||
167 | SocketMode = "0600"; | ||
168 | }; | ||
169 | }; | ||
170 | systemd.user.services.niri-workspace-history = { | ||
171 | Unit = { | ||
172 | BindsTo = [ "niri.service" ]; | ||
173 | After = [ "niri.service" ]; | ||
174 | }; | ||
175 | Install = { | ||
176 | WantedBy = [ "niri.service" ]; | ||
177 | }; | ||
178 | Service = { | ||
179 | Type = "simple"; | ||
180 | Sockets = [ "niri-workspace-history.socket" ]; | ||
181 | ExecStart = pkgs.writers.writePython3 "niri-workspace-history" {} '' | ||
182 | import os | ||
183 | import socket | ||
184 | import json | ||
185 | import sys | ||
186 | from collections import defaultdict | ||
187 | from threading import Thread, Lock | ||
188 | from socketserver import StreamRequestHandler, ThreadingTCPServer | ||
189 | from contextlib import contextmanager | ||
190 | from io import TextIOWrapper | ||
191 | |||
192 | |||
193 | @contextmanager | ||
194 | def detaching(thing): | ||
195 | try: | ||
196 | yield thing | ||
197 | finally: | ||
198 | thing.detach() | ||
199 | |||
200 | |||
201 | workspace_history = defaultdict(list) | ||
202 | history_lock = Lock() | ||
203 | |||
204 | |||
205 | def monitor_niri(): | ||
206 | workspaces = list() | ||
207 | |||
208 | def focus_workspace(output, workspace): | ||
209 | global workspace_history, history_lock | ||
210 | |||
211 | with history_lock: | ||
212 | workspace_history[output] = [workspace] + [ws for ws in workspace_history[output] if ws != workspace] # noqa: E501 | ||
213 | print(json.dumps(workspace_history), file=sys.stderr) | ||
214 | |||
215 | sock = socket.socket(socket.AF_UNIX, socket.SOCK_STREAM) | ||
216 | sock.connect(os.environ["NIRI_SOCKET"]) | ||
217 | sock.send(b"\"EventStream\"\n") | ||
218 | for line in sock.makefile(buffering=1, encoding='utf-8'): | ||
219 | if line_json := json.loads(line): | ||
220 | if "WorkspacesChanged" in line_json: | ||
221 | workspaces = line_json["WorkspacesChanged"]["workspaces"] | ||
222 | for ws in workspaces: | ||
223 | if ws["is_focused"]: | ||
224 | focus_workspace(ws["output"], ws["id"]) | ||
225 | if "WorkspaceActivated" in line_json: | ||
226 | for ws in workspaces: | ||
227 | if ws["id"] != line_json["WorkspaceActivated"]["id"]: | ||
228 | continue | ||
229 | focus_workspace(ws["output"], ws["id"]) | ||
230 | break | ||
231 | |||
232 | |||
233 | class RequestHandler(StreamRequestHandler): | ||
234 | def handle(self): | ||
235 | global workspace_history, history_lock | ||
236 | |||
237 | with detaching(TextIOWrapper(self.wfile, encoding='utf-8', write_through=True)) as out: # noqa: E501 | ||
238 | with history_lock: | ||
239 | json.dump(workspace_history, out) | ||
240 | |||
241 | |||
242 | class Server(ThreadingTCPServer): | ||
243 | def __init__(self): | ||
244 | ThreadingTCPServer.__init__(self, ("", 8000), RequestHandler, bind_and_activate=False) # noqa: E501 | ||
245 | self.socket = socket.fromfd(3, self.address_family, self.socket_type) | ||
246 | |||
247 | |||
248 | def run_server(): | ||
249 | with Server() as server: | ||
250 | server.serve_forever() | ||
251 | |||
252 | |||
253 | niri = Thread(target=monitor_niri) | ||
254 | niri.daemon = True | ||
255 | niri.start() | ||
256 | |||
257 | server_thread = Thread(target=run_server) | ||
258 | server_thread.daemon = True | ||
259 | server_thread.start() | ||
260 | |||
261 | while True: | ||
262 | server_thread.join(timeout=0.5) | ||
263 | niri.join(timeout=0.5) | ||
264 | |||
265 | if not (niri.is_alive() and server_thread.is_alive()): | ||
266 | break | ||
267 | ''; | ||
268 | }; | ||
269 | }; | ||
270 | |||
271 | programs.niri.settings = { | ||
272 | prefer-no-csd = true; | ||
273 | screenshot-path = "${config.home.homeDirectory}/screenshots"; | ||
274 | |||
275 | hotkey-overlay.skip-at-startup = true; | ||
276 | |||
277 | input = { | ||
278 | keyboard = { | ||
279 | repeat-delay = 300; | ||
280 | repeat-rate = 50; | ||
281 | |||
282 | xkb = { | ||
283 | layout = "us,us"; | ||
284 | variant = "dvp,"; | ||
285 | options = "compose:caps,grp:win_space_toggle"; | ||
286 | }; | ||
287 | }; | ||
288 | |||
289 | workspace-auto-back-and-forth = true; | ||
290 | # focus-follows-mouse.enable = true; | ||
291 | warp-mouse-to-focus = true; | ||
292 | }; | ||
293 | |||
294 | outputs = { | ||
295 | "eDP-1" = { | ||
296 | scale = 1.5; | ||
297 | position = { x = 0; y = 0; }; | ||
298 | }; | ||
299 | "Ancor Communications Inc ASUS PB287Q 0x0000DD9B" = { | ||
300 | scale = 1.5; | ||
301 | position = { x = 2560; y = 0; }; | ||
302 | }; | ||
303 | "HP Inc. HP 727pu CN4417143K" = { | ||
304 | mode = { width = 2560; height = 1440; refresh = 119.998; }; | ||
305 | scale = 1; | ||
306 | position = { x = 2560; y = 0; }; | ||
307 | variable-refresh-rate = "on-demand"; | ||
308 | }; | ||
309 | }; | ||
310 | |||
311 | environment = { | ||
312 | NIXOS_OZONE_WL = "1"; | ||
313 | QT_QPA_PLATFORM = "wayland"; | ||
314 | QT_WAYLAND_DISABLE_WINDOWDECORATION = "1"; | ||
315 | GDK_BACKEND = "wayland"; | ||
316 | SDL_VIDEODRIVER = "wayland"; | ||
317 | DISPLAY = ":0"; | ||
318 | }; | ||
319 | |||
320 | debug.render-drm-device = "/dev/dri/by-path/pci-0000:00:02.0-render"; | ||
321 | |||
322 | animations = { | ||
323 | slowdown = 0.5; | ||
324 | workspace-switch = null; | ||
325 | }; | ||
326 | |||
327 | layout = { | ||
328 | gaps = 8; | ||
329 | struts = { left = 0; right = 0; top = 0; bottom = 0; }; | ||
330 | focus-ring = { | ||
331 | width = 2; | ||
332 | active.gradient = { | ||
333 | from = "hsla(195 100% 60% 0.75)"; | ||
334 | to = "hsla(155 100% 50% 0.75)"; | ||
335 | angle = 29; | ||
336 | relative-to = "workspace-view"; | ||
337 | }; | ||
338 | inactive.gradient = { | ||
339 | from = "hsla(0 0% 42% 0.66)"; | ||
340 | to = "hsla(0 0% 35% 0.66)"; | ||
341 | angle = 29; | ||
342 | relative-to = "workspace-view"; | ||
343 | }; | ||
344 | }; | ||
345 | |||
346 | preset-column-widths = [ | ||
347 | { proportion = 1. / 4.; } | ||
348 | { proportion = 1. / 3.; } | ||
349 | { proportion = 1. / 2.; } | ||
350 | { proportion = 2. / 3.; } | ||
351 | { proportion = 3. / 4.; } | ||
352 | ]; | ||
353 | default-column-width.proportion = 1. / 2.; | ||
354 | preset-window-heights = [ | ||
355 | { proportion = 1. / 3.; } | ||
356 | { proportion = 1. / 2.; } | ||
357 | { proportion = 2. / 3.; } | ||
358 | { proportion = 1.; } | ||
359 | ]; | ||
360 | |||
361 | always-center-single-column = true; | ||
362 | }; | ||
363 | |||
364 | cursor.hide-when-typing = true; | ||
365 | |||
366 | input = { | ||
367 | touchpad.enable = false; | ||
368 | trackball = { | ||
369 | scroll-method = "on-button-down"; | ||
370 | scroll-button = 278; | ||
371 | }; | ||
372 | }; | ||
373 | |||
374 | workspaces = { | ||
375 | "001" = { name = "pwctl"; open-on-output = "eDP-1"; }; | ||
376 | "002" = { name = "kpxc"; open-on-output = "eDP-1"; }; | ||
377 | "003" = { name = "bmgr"; open-on-output = "eDP-1"; }; | ||
378 | "004" = { name = "term"; open-on-output = "eDP-1"; }; | ||
379 | "005" = { name = "edit"; open-on-output = "eDP-1"; }; | ||
380 | "006" = { name = "eff"; open-on-output = "eDP-1"; }; | ||
381 | "101".name = "comm"; | ||
382 | "102".name = "web"; | ||
383 | # "104".name = "read"; | ||
384 | # "105".name = "mon"; | ||
385 | "110".name = "vid"; | ||
386 | "120".name = "bmr"; | ||
387 | }; | ||
388 | |||
389 | window-rules = [ | ||
390 | { | ||
391 | matches = [ { is-floating = true; } ]; | ||
392 | geometry-corner-radius = | ||
393 | let | ||
394 | allCorners = r: { bottom-left = r; bottom-right = r; top-left = r; top-right = r; }; | ||
395 | in allCorners 8.; | ||
396 | clip-to-geometry = true; | ||
397 | } | ||
398 | { | ||
399 | matches = [ { app-id = "^com\.saivert\.pwvucontrol$"; } ]; | ||
400 | open-on-workspace = "pwctl"; | ||
401 | open-maximized = true; | ||
402 | } | ||
403 | { | ||
404 | matches = [ { app-id = "^com\.github\.wwmm\.easyeffects$"; } ]; | ||
405 | open-on-workspace = "eff"; | ||
406 | open-maximized = true; | ||
407 | } | ||
408 | { | ||
409 | matches = [ { app-id = "^\.blueman-manager-wrapped$"; } ]; | ||
410 | open-on-workspace = "bmgr"; | ||
411 | open-maximized = true; | ||
412 | } | ||
413 | { | ||
414 | matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ]; | ||
415 | block-out-from = "screencast"; | ||
416 | } | ||
417 | { | ||
418 | matches = [ { app-id = "^org\.keepassxc\.KeePassXC$"; } ]; | ||
419 | excludes = [ | ||
420 | { title = "^Unlock Database.*"; } | ||
421 | { title = "^Access Request.*"; } | ||
422 | { title = ".*Passkey credentials$"; } | ||
423 | ]; | ||
424 | open-on-workspace = "kpxc"; | ||
425 | open-maximized = true; | ||
426 | open-focused = false; | ||
427 | } | ||
428 | { | ||
429 | matches = [ | ||
430 | { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Unlock Database.*"; } | ||
431 | { app-id = "^org\.keepassxc\.KeePassXC$"; title = "^Access Request.*"; } | ||
432 | { app-id = "^org\.keepassxc\.KeePassXC$"; title = ".*Passkey credentials$"; } | ||
433 | ]; | ||
434 | open-focused = true; | ||
435 | open-floating = true; | ||
436 | } | ||
437 | { | ||
438 | matches = [ { app-id = "^kitty-scratch$"; } ]; | ||
439 | open-on-workspace = "term"; | ||
440 | open-maximized = true; | ||
441 | } | ||
442 | { | ||
443 | matches = [ { title = "^scratch$"; app-id = "^emacs$"; } ]; | ||
444 | open-on-workspace = "edit"; | ||
445 | open-maximized = true; | ||
446 | } | ||
447 | { | ||
448 | matches = [ | ||
449 | { app-id = "^emacs$"; } | ||
450 | { app-id = "^firefox$"; } | ||
451 | ]; | ||
452 | default-column-width.proportion = 2. / 3.; | ||
453 | } | ||
454 | { | ||
455 | matches = [ | ||
456 | { app-id = "^kitty$"; } | ||
457 | { app-id = "^kitty-play$"; } | ||
458 | ]; | ||
459 | default-column-width.proportion = 1. / 3.; | ||
460 | } | ||
461 | { | ||
462 | matches = [ | ||
463 | { app-id = "^thunderbird$"; } | ||
464 | { app-id = "^Element$"; } | ||
465 | { app-id = "^Rainbow$"; } | ||
466 | ]; | ||
467 | open-on-workspace = "comm"; | ||
468 | } | ||
469 | { | ||
470 | matches = [ { app-id = "^firefox$"; } ]; | ||
471 | open-on-workspace = "web"; | ||
472 | open-maximized = true; | ||
473 | variable-refresh-rate = true; | ||
474 | } | ||
475 | # { | ||
476 | # matches = [ | ||
477 | # { app-id = "^evince$"; } | ||
478 | # { app-id = "^imv$"; } | ||
479 | # { app-id = "^org\.pwmt\.zathura$"; } | ||
480 | # ]; | ||
481 | # open-on-workspace = "read"; | ||
482 | # } | ||
483 | { | ||
484 | matches = [ { app-id = "^mpv$"; } ]; | ||
485 | open-on-workspace = "vid"; | ||
486 | default-column-width.proportion = 1.; | ||
487 | variable-refresh-rate = true; | ||
488 | } | ||
489 | { | ||
490 | matches = [ { app-id = "^kitty-play$"; } ]; | ||
491 | open-on-workspace = "vid"; | ||
492 | open-focused = false; | ||
493 | } | ||
494 | # { | ||
495 | # matches = [ | ||
496 | # { app-id = "^qemu$"; } | ||
497 | # { app-id = "^virt-manager$"; } | ||
498 | # ]; | ||
499 | # open-on-workspace = "mon"; | ||
500 | # } | ||
501 | { | ||
502 | matches = [ { app-id = "^pdfpc$"; } ]; | ||
503 | default-column-width.proportion = 1.; | ||
504 | } | ||
505 | { | ||
506 | matches = [ { app-id = "^pdfpc$"; title = "^pdfpc - presentation"; } ]; | ||
507 | open-on-workspace = "bmr"; | ||
508 | open-fullscreen = true; | ||
509 | } | ||
510 | { | ||
511 | matches = [ | ||
512 | { app-id = "^Gimp-"; title = "^Quit GIMP$"; } | ||
513 | { app-id = "^org\.kde\.polkit-kde-authentication-agent-1$"; } | ||
514 | { app-id = "^xdg-desktop-portal-gtk$"; } | ||
515 | ]; | ||
516 | open-floating = true; | ||
517 | } | ||
518 | ]; | ||
519 | layer-rules = [ | ||
520 | { matches = [ | ||
521 | { namespace = "^notifications$"; } | ||
522 | { namespace = "^waybar$"; } | ||
523 | ]; | ||
524 | block-out-from = "screencast"; | ||
525 | } | ||
526 | ]; | ||
527 | |||
528 | binds = with config.lib.niri.actions; { | ||
529 | "Mod+Slash".action = show-hotkey-overlay; | ||
530 | |||
531 | "Mod+Return".action = spawn terminal; | ||
532 | "Mod+Q".action = close-window; | ||
533 | "Mod+O".action = spawn (lib.getExe config.programs.fuzzel.package); | ||
534 | "Mod+Shift+O".action = spawn (lib.getExe config.programs.fuzzel.package) "--list-executables-in-path"; | ||
535 | |||
536 | "Mod+Alt+E".action = spawn (lib.getExe' config.services.emacs.package "emacsclient") "-c"; | ||
537 | "Mod+Alt+Y".action = spawn (lib.getExe (pkgs.writeShellApplication { | ||
538 | name = "queue-yt-dlp"; | ||
539 | runtimeInputs = with pkgs; [ wl-clipboard-rs socat ]; | ||
540 | text = '' | ||
541 | socat STDIO UNIX-CONNECT:"$XDG_RUNTIME_DIR"/yt-dlp.sock <<<$'{ "urls": ["'"$(wl-paste)"$'"] }' | ||
542 | ''; | ||
543 | })); | ||
544 | "Mod+Alt+L".action = spawn (lib.getExe (pkgs.writeShellApplication { | ||
545 | name = "queue-yt-dlp"; | ||
546 | runtimeInputs = with pkgs; [ wl-clipboard-rs config.programs.kitty.package ]; | ||
547 | text = '' | ||
548 | exec -- kitty --app-id kitty-play --directory "$HOME"/media mpv "$(wl-paste)" | ||
549 | ''; | ||
550 | })); | ||
551 | |||
552 | "Mod+U".action = spawn (lib.getExe (pkgs.writeShellApplication { | ||
553 | name = "qalc-fuzzel"; | ||
554 | runtimeInputs = with pkgs; [ wl-clipboard-rs libqalculate config.programs.fuzzel.package coreutils findutils libnotify gnugrep ]; | ||
555 | text = '' | ||
556 | RESULTS_DIR="$HOME/.cache/qalc-fuzzel" | ||
557 | prev() { | ||
558 | FOUND=false | ||
559 | while IFS= read -r line; do | ||
560 | [[ -n "$line" ]] || continue | ||
561 | FOUND=true | ||
562 | echo "$line" | ||
563 | done < <(export LC_ALL=C.UTF-8; echo; find "$RESULTS_DIR" -type f -printf $'%T@ %p\n' | sort -n | cut -d' ' -f2- | xargs -r cat) | ||
564 | $FOUND || echo | ||
565 | } | ||
566 | FUZZEL_RES=$(prev | fuzzel --dmenu --prompt "qalc> ") || exit $? | ||
567 | if [[ "$FUZZEL_RES" =~ .*\ =\ .* ]]; then | ||
568 | QALC_RES="$FUZZEL_RES" | ||
569 | QALC_RET=0 | ||
570 | else | ||
571 | QALC_RES=$(qalc "$FUZZEL_RES" 2>&1) | ||
572 | QALC_RET=$? | ||
573 | fi | ||
574 | [[ -n "$QALC_RES" ]] || exit 1 | ||
575 | EXISTING=false | ||
576 | set +o pipefail | ||
577 | grep -Fxrl "$QALC_RES" "$RESULTS_DIR" | xargs -r touch | ||
578 | [[ ''${PIPESTATUS[0]} -eq 0 ]] && EXISTING=true | ||
579 | set -o pipefail | ||
580 | if [[ $QALC_RET -eq 0 ]] && ! $EXISTING; then | ||
581 | set +o pipefail | ||
582 | RES_FILE="$RESULTS_DIR"/$(date -uIs).$(tr -Cd 'a-zA-Z0-9' </dev/random | head -c 10) | ||
583 | set -o pipefail | ||
584 | cat >"$RES_FILE" <<<"$QALC_RES" | ||
585 | fi | ||
586 | [[ "$QALC_RES" =~ .*\ =\ (.*) ]] && QALC_RES="''${BASH_REMATCH[1]}" | ||
587 | [[ $QALC_RET -eq 0 ]] && wl-copy "$QALC_RES" | ||
588 | notify-send "$QALC_RES" | ||
589 | ''; | ||
590 | })); | ||
591 | "Mod+E".action = spawn (lib.getExe (pkgs.writeShellApplication { | ||
592 | name = "emoji-fuzzel"; | ||
593 | runtimeInputs = with pkgs; [ config.programs.fuzzel.package wtype wl-clipboard-rs ]; | ||
594 | text = '' | ||
595 | FUZZEL_RES=$(fuzzel --dmenu --prompt "emoji> " <"$HOME"/.local/share/emoji-data/list.txt) || exit $? | ||
596 | [[ -n "$FUZZEL_RES" ]] || exit 1 | ||
597 | wl-copy "$(cut -d ':' -f 1 <<<"$FUZZEL_RES" | tr -d '\n')" && wtype -k XF86Paste | ||
598 | ''; | ||
599 | })); | ||
600 | "Print".action = spawn (lib.getExe (pkgs.writeShellApplication { | ||
601 | name = "screenshot"; | ||
602 | runtimeInputs = with pkgs; [ grim slurp wl-clipboard-rs coreutils ]; | ||
603 | text = '' | ||
604 | grim -g "$(slurp -b 00000080 -c FFFFFFFF -s 00000000 -w 1)" - \ | ||
605 | | tee "$HOME/screenshots/$(date +"%Y-%m-%dT%H:%M:%S").png" \ | ||
606 | | wl-copy --type image/png | ||
607 | ''; | ||
608 | })); | ||
609 | "Shift+Print".action = spawn (lib.getExe (pkgs.writeShellApplication { | ||
610 | name = "screenshot"; | ||
611 | runtimeInputs = with pkgs; [ grim niri gojq wl-clipboard-rs coreutils ]; | ||
612 | text = '' | ||
613 | grim -o "$(niri msg -j workspaces | jq -r '.[] | select(.is_focused) | .output')" - \ | ||
614 | | tee "$HOME/screenshots/$(date +"%Y-%m-%dT%H:%M:%S").png" \ | ||
615 | | wl-copy --type image/png | ||
616 | ''; | ||
617 | })); | ||
618 | "Mod+B".action = with-select-window-action ".workspace_id == ($active_workspace | tonumber)" "{\"Action\":{\"FocusWindow\":{\"id\": .id}}}"; | ||
619 | "Mod+Shift+B".action = with-select-window-action "true" "{\"Action\":{\"FocusWindow\":{\"id\": .id}}}"; | ||
620 | |||
621 | "Mod+H".action = focus-column-left; | ||
622 | "Mod+T".action = focus-window-down; | ||
623 | "Mod+N".action = focus-window-up; | ||
624 | "Mod+S".action = focus-column-right; | ||
625 | |||
626 | "Mod+Shift+H".action = move-column-left; | ||
627 | "Mod+Shift+T".action = move-window-down; | ||
628 | "Mod+Shift+N".action = move-window-up; | ||
629 | "Mod+Shift+S".action = move-column-right; | ||
630 | |||
631 | "Mod+Control+H".action = focus-monitor-left; | ||
632 | "Mod+Control+T".action = focus-monitor-down; | ||
633 | "Mod+Control+N".action = focus-monitor-up; | ||
634 | "Mod+Control+S".action = focus-monitor-right; | ||
635 | |||
636 | "Mod+Shift+Control+H".action = move-workspace-to-monitor-left; | ||
637 | "Mod+Shift+Control+T".action = move-workspace-to-monitor-down; | ||
638 | "Mod+Shift+Control+N".action = move-workspace-to-monitor-up; | ||
639 | "Mod+Shift+Control+S".action = move-workspace-to-monitor-right; | ||
640 | |||
641 | "Mod+G".action = focus-adjacent-workspace "down"; | ||
642 | "Mod+C".action = focus-adjacent-workspace "up"; | ||
643 | |||
644 | "Mod+Shift+G".action = move-column-to-adjacent-workspace "down"; | ||
645 | "Mod+Shift+C".action = move-column-to-adjacent-workspace "up"; | ||
646 | |||
647 | "Mod+Shift+Control+G".action = move-workspace-down; | ||
648 | "Mod+Shift+Control+C".action = move-workspace-up; | ||
649 | |||
650 | "Mod+ParenLeft".action = focus-workspace "comm"; | ||
651 | "Mod+Shift+ParenLeft".action = move-column-to-workspace "comm"; | ||
652 | |||
653 | "Mod+ParenRight".action = focus-workspace "web"; | ||
654 | "Mod+Shift+ParenRight".action = move-column-to-workspace "web"; | ||
655 | |||
656 | "Mod+BraceRight".action = focus-workspace "read"; | ||
657 | "Mod+Shift+BraceRight".action = move-column-to-workspace "read"; | ||
658 | |||
659 | "Mod+BraceLeft".action = focus-workspace "mon"; | ||
660 | "Mod+Shift+BraceLeft".action = move-column-to-workspace "mon"; | ||
661 | |||
662 | "Mod+Asterisk".action = focus-workspace "vid"; | ||
663 | "Mod+Shift+Asterisk".action = move-column-to-workspace "vid"; | ||
664 | |||
665 | "Mod+Plus".action = with-unnamed-workspace-action ''{"Action":{"FocusWorkspace":{"reference":{"Id": .id}}}}''; | ||
666 | "Mod+Shift+Plus".action = with-unnamed-workspace-action ''{"Action":{"MoveColumnToWorkspace":{"reference":{"Id": .id}}}}''; | ||
667 | |||
668 | "Mod+M".action = consume-or-expel-window-left; | ||
669 | "Mod+W".action = consume-or-expel-window-right; | ||
670 | |||
671 | "Mod+R".action = switch-preset-column-width; | ||
672 | "Mod+Shift+R".action = switch-preset-window-height; | ||
673 | "Mod+F".action = center-column; | ||
674 | "Mod+Shift+F".action = maximize-column; | ||
675 | "Mod+Shift+Ctrl+F".action = fullscreen-window; | ||
676 | |||
677 | "Mod+V".action = switch-focus-between-floating-and-tiling; | ||
678 | "Mod+Shift+V".action = toggle-window-floating; | ||
679 | |||
680 | "Mod+Left".action = set-column-width "-10%"; | ||
681 | "Mod+Down".action = set-window-height "-10%"; | ||
682 | "Mod+Up".action = set-window-height "+10%"; | ||
683 | "Mod+Right".action = set-column-width "+10%"; | ||
684 | |||
685 | "Mod+Shift+Z" = { | ||
686 | action = spawn (lib.getExe niri) "msg" "action" "power-off-monitors"; | ||
687 | allow-when-locked = true; | ||
688 | }; | ||
689 | "Mod+Shift+L".action = spawn loginctl "lock-session"; | ||
690 | "Mod+Shift+E".action = quit; | ||
691 | "Mod+Shift+Minus" = { | ||
692 | action = spawn systemctl "suspend"; | ||
693 | allow-when-locked = true; | ||
694 | }; | ||
695 | "Mod+Shift+Control+Minus" = { | ||
696 | action = spawn systemctl "hibernate"; | ||
697 | allow-when-locked = true; | ||
698 | }; | ||
699 | "Mod+Shift+P" = { | ||
700 | action = spawn (lib.getExe pkgs.playerctl) "-a" "pause"; | ||
701 | allow-when-locked = true; | ||
702 | }; | ||
703 | |||
704 | "XF86MonBrightnessUp" = { | ||
705 | action = spawn swayosd-client "--brightness" "raise"; | ||
706 | allow-when-locked = true; | ||
707 | }; | ||
708 | "XF86MonBrightnessDown" = { | ||
709 | action = spawn swayosd-client "--brightness" "lower"; | ||
710 | allow-when-locked = true; | ||
711 | }; | ||
712 | "XF86AudioRaiseVolume" = { | ||
713 | action = spawn swayosd-client "--output-volume" "raise"; | ||
714 | allow-when-locked = true; | ||
715 | }; | ||
716 | "XF86AudioLowerVolume" = { | ||
717 | action = spawn swayosd-client "--output-volume" "lower"; | ||
718 | allow-when-locked = true; | ||
719 | }; | ||
720 | "XF86AudioMute" = { | ||
721 | action = spawn swayosd-client "--output-volume" "mute-toggle"; | ||
722 | allow-when-locked = true; | ||
723 | }; | ||
724 | "XF86AudioMicMute" = { | ||
725 | action = spawn swayosd-client "--input-volume" "mute-toggle"; | ||
726 | allow-when-locked = true; | ||
727 | }; | ||
728 | |||
729 | "Mod+Semicolon".action = spawn makoctl "dismiss" "--group"; | ||
730 | "Mod+Shift+Semicolon".action = spawn makoctl "dismiss" "--all"; | ||
731 | "Mod+Period".action = spawn makoctl "menu" (lib.getExe config.programs.fuzzel.package) "--dmenu"; | ||
732 | "Mod+Comma".action = spawn makoctl "restore"; | ||
733 | |||
734 | "Mod+Control+A".action = focus-or-spawn-action-app_id "com.saivert.pwvucontrol" "pwctl" "pwvucontrol"; | ||
735 | "Mod+Control+O".action = focus-or-spawn-action-app_id "com.github.wwmm.easyeffects" "eff" "easyeffects"; | ||
736 | "Mod+Control+P".action = focus-or-spawn-action-app_id "org.keepassxc.KeePassXC" "kpxc" "keepassxc"; | ||
737 | "Mod+Control+B".action = focus-or-spawn-action-app_id ".blueman-manager-wrapped" "bmgr" "blueman-manager"; | ||
738 | "Mod+Control+Return".action = focus-or-spawn-action-app_id "kitty-scratch" "term" "kitty" "--app-id" "kitty-scratch"; | ||
739 | "Mod+Control+E".action = focus-or-spawn-action "select(.app_id == \"emacs\" and .title == \"scratch\")" "edit" "emacsclient" "-c" "--frame-parameters=(quote (name . \"scratch\"))"; | ||
740 | }; | ||
741 | }; | ||
742 | }; | ||
743 | } | ||