summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/hyprland.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/hyprland.nix')
-rw-r--r--accounts/gkleen@sif/hyprland.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/hyprland.nix b/accounts/gkleen@sif/hyprland.nix
index 4e4eb091..06d146a0 100644
--- a/accounts/gkleen@sif/hyprland.nix
+++ b/accounts/gkleen@sif/hyprland.nix
@@ -203,6 +203,19 @@
203 grim -g "$(slurp -b 00000080 -c FFFFFFFF -s 00000000 -w 1)" "$outFile" 203 grim -g "$(slurp -b 00000080 -c FFFFFFFF -s 00000000 -w 1)" "$outFile"
204 wl-copy --type image/png <"$outFile" 204 wl-copy --type image/png <"$outFile"
205 ''}" 205 ''}"
206 "SHIFT, Print, exec, ${pkgs.writeShellScript "screenshot" ''
207 export PATH="${lib.makeBinPath (with pkgs; [ grim jq wl-clipboard-rs coreutils ])}:$PATH"
208
209 outFile="$HOME/screenshots/$(date +"%Y-%m-%dT%H:%M:%S").png"
210 grim -o "$(hyprctl monitors -j | jq -r '.[] | select(.focused) | .name')" "$outFile"
211 wl-copy --type image/png <"$outFile"
212 ''}"
213 "CTRL SHIFT, Print, exec, ${pkgs.runCommand "picker" {
214 buildInputs = [ pkgs.makeWrapper ];
215 } ''
216 makeWrapper ${lib.getExe pkgs.hyprpicker} $out \
217 --prefix PATH : ${lib.makeBinPath [pkgs.wl-clipboard-rs]}
218 ''} -a"
206 219
207 "$mainMod CTRL, return, togglespecialworkspace, term" 220 "$mainMod CTRL, return, togglespecialworkspace, term"
208 "$mainMod CTRL, e, togglespecialworkspace, edit" 221 "$mainMod CTRL, e, togglespecialworkspace, edit"