summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/dunst-settings.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/dunst-settings.nix')
-rw-r--r--accounts/gkleen@sif/dunst-settings.nix67
1 files changed, 67 insertions, 0 deletions
diff --git a/accounts/gkleen@sif/dunst-settings.nix b/accounts/gkleen@sif/dunst-settings.nix
new file mode 100644
index 00000000..8abdfc5a
--- /dev/null
+++ b/accounts/gkleen@sif/dunst-settings.nix
@@ -0,0 +1,67 @@
1{ pkgs, ... }:
2{
3 global = {
4 font = "Monospace 6";
5 markup = "full";
6 format = "<i>%s</i> %p\\n%b";
7 alignment = "left";
8 geometry = "1216x10-32+64";
9 shrink = true;
10 monitor = 0;
11 follow = "none";
12 padding = 6;
13 horizontal_padding = 6;
14 separator_height = 1;
15 separator_color = "frame";
16 idle_threshold = 0;
17
18 transparency = 10;
19
20 frame_width = 1;
21 frame_color = "#999999";
22
23 word_wrap = true;
24 show_age_threshold = 15;
25 show_indicators = false;
26 icon_position = "right";
27 sort = false;
28 sticky_history = false;
29
30 dmenu = "${pkgs.dmenu}/bin/dmenu";
31 };
32 shortcuts = {
33 close = "ctrl+space";
34 close_all = "ctrl+shift+space";
35 history = "ctrl+comma";
36 context = "ctrl+period";
37 };
38 urgency_low = {
39 background = "#000000";
40 foreground = "#999999";
41 timeout = 5;
42 };
43 urgency_normal = {
44 background = "#000000";
45 foreground = "#ffffff";
46 timeout = 15;
47 };
48 urgency_critical = {
49 background = "#900000";
50 foreground = "#ffffff";
51 timeout = 0;
52 };
53 pulseaudio-ctl = {
54 summary = "Volume *";
55 body = "Current is *";
56 set_stack_tag = "volume";
57 history_ignore = true;
58 };
59 mail = {
60 appname = "notmuch";
61 timeout = 0;
62 };
63 zulip = {
64 appname = "Zulip";
65 timeout = 0;
66 };
67}