diff options
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r-- | accounts/gkleen@sif/default.nix | 59 |
1 files changed, 51 insertions, 8 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix index 9dbe4634..991d7f7f 100644 --- a/accounts/gkleen@sif/default.nix +++ b/accounts/gkleen@sif/default.nix | |||
@@ -10,6 +10,43 @@ let | |||
10 | mimeType = "text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;"; | 10 | mimeType = "text/english;text/plain;text/x-makefile;text/x-c++hdr;text/x-c++src;text/x-chdr;text/x-csrc;text/x-java;text/x-moc;text/x-pascal;text/x-tcl;text/x-tex;application/x-shellscript;text/x-c;text/x-c++;"; |
11 | exec = "${config.home-manager.users.${userName}.programs.emacs.package}/bin/emacsclient -a \"\" %F"; | 11 | exec = "${config.home-manager.users.${userName}.programs.emacs.package}/bin/emacsclient -a \"\" %F"; |
12 | }; | 12 | }; |
13 | emacsScratch = pkgs.stdenv.mkDerivation rec { | ||
14 | pname = "scratch"; | ||
15 | version = "0077334cc299aa7885f804d88f52cdb1b35caf71"; | ||
16 | |||
17 | src = pkgs.fetchFromGitHub { | ||
18 | owner = "ffevotte"; | ||
19 | repo = "scratch.el"; | ||
20 | rev = version; | ||
21 | sha256 = "sha256-FUkKJ+1COGzgllzzv51yUIjMZI6slOFVExdwWl2ZEBA="; | ||
22 | }; | ||
23 | |||
24 | phases = [ "installPhase" ]; | ||
25 | |||
26 | installPhase = '' | ||
27 | mkdir -p $out/share/emacs/site-lisp | ||
28 | cp $src/scratch.el $out/share/emacs/site-lisp/default.el | ||
29 | ''; | ||
30 | }; | ||
31 | muteScript = pkgs.stdenv.mkDerivation { | ||
32 | name = "mute"; | ||
33 | src = ./scripts/mute.zsh; | ||
34 | |||
35 | buildInputs = with pkgs; [ makeWrapper ]; | ||
36 | |||
37 | phases = [ "installPhase" ]; | ||
38 | |||
39 | installPhase = '' | ||
40 | mkdir -p $out/bin | ||
41 | install -m 0755 $src $out/bin/mute | ||
42 | wrapProgram $out/bin/mute \ | ||
43 | --prefix PATH : ${pkgs.zsh}/bin \ | ||
44 | --prefix PATH : ${pkgs.findutils}/bin \ | ||
45 | --prefix PATH : ${pkgs.util-linux}/bin \ | ||
46 | --prefix PATH : ${pkgs.coreutils}/bin \ | ||
47 | --prefix PATH : ${pkgs.pulseaudio}/bin | ||
48 | ''; | ||
49 | }; | ||
13 | in { | 50 | in { |
14 | imports = with flake.nixosModules.userProfiles.${userName}; [ | 51 | imports = with flake.nixosModules.userProfiles.${userName}; [ |
15 | mpv | 52 | mpv |
@@ -20,8 +57,8 @@ in { | |||
20 | ssh = { | 57 | ssh = { |
21 | matchBlocks = import ./ssh-hosts.nix; # customUtils.recImport { dir = ./ssh-hosts; }; | 58 | matchBlocks = import ./ssh-hosts.nix; # customUtils.recImport { dir = ./ssh-hosts; }; |
22 | extraConfig = '' | 59 | extraConfig = '' |
23 | Match host uniworx3.ifi.lmu.de,uniworx4.ifi.lmu.de,uni2workgw.ifi.lmu.de,blackbeard.tcs.ifi.lmu.de,gitlab2.rz.ifi.lmu.de,oregon.tcs.ifi.lmu.de !exec "nc -z -w 1 %h %p &>/dev/null" | 60 | Match host uniworx3.ifi.lmu.de,uniworx4.ifi.lmu.de,uniworx5.ifi.lmu.de,uni2workgw.ifi.lmu.de,blackbeard.tcs.ifi.lmu.de,gitlab2.rz.ifi.lmu.de,oregon.tcs.ifi.lmu.de !exec "nc -z -w 1 %h %p &>/dev/null" |
24 | ProxyJump gate | 61 | ProxyJump gate2 |
25 | 62 | ||
26 | Host * | 63 | Host * |
27 | ''; | 64 | ''; |
@@ -33,8 +70,8 @@ in { | |||
33 | evil evil-dvorak evil-magit undo-tree magit haskell-mode | 70 | evil evil-dvorak evil-magit undo-tree magit haskell-mode |
34 | nix-mode yaml-mode json-mode shakespeare-mode | 71 | nix-mode yaml-mode json-mode shakespeare-mode |
35 | smart-mode-line highlight-parentheses highlight-symbol | 72 | smart-mode-line highlight-parentheses highlight-symbol |
36 | notmuch ag sass-mode lua-mode fira-code-mode | 73 | notmuch ag sass-mode lua-mode fira-code-mode use-package |
37 | use-package use-package-ensure-system-package git-gutter | 74 | use-package-ensure-system-package git-gutter emacsScratch |
38 | ]; | 75 | ]; |
39 | }; | 76 | }; |
40 | firefox = { | 77 | firefox = { |
@@ -97,12 +134,18 @@ in { | |||
97 | docs = "$HOME/documents"; | 134 | docs = "$HOME/documents"; |
98 | dl = "$HOME/Downloads"; | 135 | dl = "$HOME/Downloads"; |
99 | flk = "$HOME/config/nixos-flakes"; | 136 | flk = "$HOME/config/nixos-flakes"; |
137 | fsk-timi = "$HOME/projects/21s/fsk-timi"; | ||
138 | }; | ||
139 | |||
140 | obs-studio = { | ||
141 | enable = true; | ||
142 | plugins = with pkgs; [obs-v4l2sink]; | ||
100 | }; | 143 | }; |
101 | }; | 144 | }; |
102 | 145 | ||
103 | services = { | 146 | services = { |
104 | dunst = { | 147 | dunst = { |
105 | settings = import ./dunst-settings.nix; | 148 | settings = import ./dunst-settings.nix inputs; |
106 | iconTheme = cfg.gtk.iconTheme; | 149 | iconTheme = cfg.gtk.iconTheme; |
107 | enable = true; | 150 | enable = true; |
108 | }; | 151 | }; |
@@ -130,8 +173,8 @@ in { | |||
130 | sxhkd = { | 173 | sxhkd = { |
131 | enable = true; | 174 | enable = true; |
132 | keybindings = { | 175 | keybindings = { |
133 | "button8" = "${pkgs.pulseaudio}/bin/pacmd set-source-mute @DEFAULT_SOURCE@ 0"; | 176 | "button8" = "${muteScript}/bin/mute unmute"; |
134 | "@button8" = "${pkgs.pulseaudio}/bin/pacmd set-source-mute @DEFAULT_SOURCE@ 1"; | 177 | "@button8" = "${muteScript}/bin/mute mute"; |
135 | "button9" = "${pkgs.pulseaudio}/bin/pacmd set-sink-mute @DEFAULT_SINK@ 1"; | 178 | "button9" = "${pkgs.pulseaudio}/bin/pacmd set-sink-mute @DEFAULT_SINK@ 1"; |
136 | "@button9" = "${pkgs.pulseaudio}/bin/pacmd set-sink-mute @DEFAULT_SINK@ 0"; | 179 | "@button9" = "${pkgs.pulseaudio}/bin/pacmd set-sink-mute @DEFAULT_SINK@ 0"; |
137 | }; | 180 | }; |
@@ -179,7 +222,7 @@ in { | |||
179 | google-play-music-desktop-player qt5ct playerctl evince | 222 | google-play-music-desktop-player qt5ct playerctl evince |
180 | thunderbird zulip zoom-us steam steam-run wireshark skype | 223 | thunderbird zulip zoom-us steam steam-run wireshark skype |
181 | virt-manager rclone cached-nix-shell xournal discord xmonad | 224 | virt-manager rclone cached-nix-shell xournal discord xmonad |
182 | worktime fira-code-symbols emacsclientDesktopItem | 225 | worktime fira-code-symbols emacsclientDesktopItem libreoffice |
183 | ]; | 226 | ]; |
184 | 227 | ||
185 | file = { | 228 | file = { |