summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix31
1 files changed, 15 insertions, 16 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index b46d021e..80f03e49 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -63,7 +63,7 @@ let
63 }; 63 };
64in { 64in {
65 imports = with flake.nixosModules.userProfiles.${userName}; [ 65 imports = with flake.nixosModules.userProfiles.${userName}; [
66 mpv yt-dlp (args: import ./xcompose.nix (inputs // args)) 66 zsh tmux mpv yt-dlp (args: import ./xcompose.nix (inputs // args))
67 ]; 67 ];
68 68
69 config = { 69 config = {
@@ -77,10 +77,10 @@ in {
77 77
78 home.stateVersion = "20.09"; 78 home.stateVersion = "20.09";
79 79
80 nixpkgs.config = { 80 # nixpkgs.config = {
81 allowUnfree = true; 81 # allowUnfree = true;
82 zathura.useMupdf = false; 82 # zathura.useMupdf = false;
83 }; 83 # };
84 84
85 nix.registry = { 85 nix.registry = {
86 "flk" = { 86 "flk" = {
@@ -186,7 +186,7 @@ in {
186 gpu-api = "vulkan"; 186 gpu-api = "vulkan";
187 }; 187 };
188 188
189 zsh.initExtra = let 189 zsh.initContent = let
190 zshrc = pkgs.resholve.mkDerivation { 190 zshrc = pkgs.resholve.mkDerivation {
191 pname = "zshrc"; 191 pname = "zshrc";
192 version = "0.0.0"; 192 version = "0.0.0";
@@ -219,7 +219,6 @@ in {
219 gnutar 219 gnutar
220 cpio 220 cpio
221 magic-wormhole 221 magic-wormhole
222 quickserve
223 cfg.programs.zsh.package 222 cfg.programs.zsh.package
224 fuse 223 fuse
225 util-linux 224 util-linux
@@ -232,6 +231,7 @@ in {
232 config.systemd.package 231 config.systemd.package
233 config.programs.ssh.package 232 config.programs.ssh.package
234 gnused 233 gnused
234 miniserve
235 ]; 235 ];
236 execer = with pkgs; [ 236 execer = with pkgs; [
237 "cannot:${lib.getExe' rpm "rpm2cpio"}" 237 "cannot:${lib.getExe' rpm "rpm2cpio"}"
@@ -240,7 +240,6 @@ in {
240 "cannot:${lib.getExe cfg.programs.git.package}" 240 "cannot:${lib.getExe cfg.programs.git.package}"
241 "cannot:${lib.getExe cpio}" 241 "cannot:${lib.getExe cpio}"
242 "cannot:${lib.getExe' magic-wormhole "wormhole"}" 242 "cannot:${lib.getExe' magic-wormhole "wormhole"}"
243 "cannot:${lib.getExe quickserve}"
244 "cannot:${lib.getExe' fuse "fusermount"}" 243 "cannot:${lib.getExe' fuse "fusermount"}"
245 "cannot:${lib.getExe less}" 244 "cannot:${lib.getExe less}"
246 "cannot:${lib.getExe' config.systemd.package "systemctl"}" 245 "cannot:${lib.getExe' config.systemd.package "systemctl"}"
@@ -322,14 +321,6 @@ in {
322 "kitty_mod+m" = "detach_window ask"; 321 "kitty_mod+m" = "detach_window ask";
323 }; 322 };
324 }; 323 };
325 wpaperd = {
326 enable = true;
327 settings.default = {
328 path = "~/.wallpapers";
329 duration = "15m";
330 mode = "center";
331 };
332 };
333 fuzzel = { 324 fuzzel = {
334 enable = true; 325 enable = true;
335 settings = { 326 settings = {
@@ -360,6 +351,14 @@ in {
360 }; 351 };
361 352
362 services = { 353 services = {
354 wpaperd = {
355 enable = true;
356 settings.default = {
357 path = "~/.wallpapers";
358 duration = "15m";
359 mode = "center";
360 };
361 };
363 emacs = { 362 emacs = {
364 enable = true; 363 enable = true;
365 socketActivation.enable = true; 364 socketActivation.enable = true;