summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix51
1 files changed, 31 insertions, 20 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index b66db697..85699bd4 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -359,7 +359,7 @@ in {
359 output = "eDP-1"; 359 output = "eDP-1";
360 modules-left = [ "hyprland/workspaces" ]; 360 modules-left = [ "hyprland/workspaces" ];
361 modules-center = [ "hyprland/window" ]; 361 modules-center = [ "hyprland/window" ];
362 modules-right = [ "custom/weather" "clock" "privacy" "tray" "backlight" "battery" "idle_inhibitor" ]; 362 modules-right = [ "custom/weather" "clock" "privacy" "tray" "pulseaudio" "backlight" "battery" "idle_inhibitor" ];
363 363
364 "custom/weather" = { 364 "custom/weather" = {
365 format = "{}"; 365 format = "{}";
@@ -419,25 +419,22 @@ in {
419 format = "{icon}"; 419 format = "{icon}";
420 format-icons = { activated = "󰈈"; deactivated = "󰈉"; }; 420 format-icons = { activated = "󰈈"; deactivated = "󰈉"; };
421 }; 421 };
422 backlight = let 422 backlight = {
423 brightnessNotify = ''
424 max=$(brightnessctl m -m)
425 curr=$(brightnessctl g -m)
426 perc=$((curr * 100 / max))
427 pgrep dunstify || dunstify -u low -a brightness "Brightness ''${perc}" "" -h int:value:''${perc}
428 '';
429 in {
430 format = "{icon}"; 423 format = "{icon}";
431 tooltip-format = "{percent}%"; 424 tooltip-format = "{percent}%";
432 format-icons = ["󰃚" "󰃛" "󰃜" "󰃝" "󰃞" "󰃟" "󰃠"]; 425 format-icons = ["󰃚" "󰃛" "󰃜" "󰃝" "󰃞" "󰃟" "󰃠"];
433 on-scroll-up = pkgs.writeShellScript "brightness-up" '' 426 on-scroll-up = "lightctl -d up";
434 brightnessctl s +1 427 on-scroll-down = "lightctl -d down";
435 ${brightnessNotify} 428 };
436 ''; 429 pulseaudio = {
437 on-scroll-down = pkgs.writeShellScript "brightness-down" '' 430 format = "{icon}";
438 brightnessctl s 1- 431 tooltip-format = "{volume}% {desc}";
439 ${brightnessNotify} 432 format-icons = ["󰕿" "󰖀" "󰕾"];
440 ''; 433 format-muted = "󰝟";
434 ignored-sinks = ["Easy Effects Sink"];
435 on-scroll-up = "volumectl -d -u up";
436 on-scroll-down = "volumectl -d -u down";
437 on-click = "volumectl -d toggle-mute";
441 }; 438 };
442 } 439 }
443 { 440 {
@@ -521,7 +518,7 @@ in {
521 #tray { 518 #tray {
522 margin: 0 2px; 519 margin: 0 2px;
523 } 520 }
524 #battery, #idle_inhibitor, #backlight { 521 #battery, #idle_inhibitor, #backlight, #pulseaudio {
525 color: @grey; 522 color: @grey;
526 margin: 0 5px 0 2px; 523 margin: 0 5px 0 2px;
527 } 524 }
@@ -629,7 +626,10 @@ in {
629 services = { 626 services = {
630 dunst = { 627 dunst = {
631 settings = import ./dunst-settings.nix inputs; 628 settings = import ./dunst-settings.nix inputs;
632 iconTheme = cfg.gtk.iconTheme; 629 iconTheme = {
630 package = pkgs.paper-icon-theme;
631 name = "Paper";
632 };
633 enable = true; 633 enable = true;
634 }; 634 };
635 emacs = { 635 emacs = {
@@ -654,7 +654,7 @@ in {
654 }; 654 };
655 # status-notifier-watcher.enable = true; 655 # status-notifier-watcher.enable = true;
656 xembed-sni-proxy.enable = true; 656 xembed-sni-proxy.enable = true;
657 pasystray.enable = true; 657 pasystray.enable = false;
658 udiskie = { 658 udiskie = {
659 enable = true; 659 enable = true;
660 automount = false; 660 automount = false;
@@ -772,6 +772,17 @@ in {
772 ]; 772 ];
773 }; 773 };
774 poweralertd.enable = true; 774 poweralertd.enable = true;
775 avizo = {
776 enable = true;
777 settings.default = {
778 time = "1.0";
779 background = "rgba(0, 0, 0, 0.8)";
780 border-color = "rgba(0, 0, 0, 1)";
781 bar-fg-color = "rgba(160, 160, 160, 1)";
782 bar-bg-color = "rgba(32, 32, 32, 0.96)";
783 # y-offset = "0.25";
784 };
785 };
775 }; 786 };
776 787
777 home.pointerCursor = { 788 home.pointerCursor = {