summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix25
1 files changed, 20 insertions, 5 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index 09864bb2..61769adb 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -99,6 +99,7 @@ in {
99 99
100 home-manager.users.${userName} = { 100 home-manager.users.${userName} = {
101 imports = [ 101 imports = [
102 ./libvirt
102 flakeInputs.nix-index-database.hmModules.nix-index 103 flakeInputs.nix-index-database.hmModules.nix-index
103 flakeInputs.impermanence.nixosModules.home-manager.impermanence 104 flakeInputs.impermanence.nixosModules.home-manager.impermanence
104 ]; 105 ];
@@ -171,7 +172,7 @@ in {
171 edit-server mediawiki editorconfig typescript-mode 172 edit-server mediawiki editorconfig typescript-mode
172 markdown-mode nftables-mode rustic lsp-mode lsp-ui 173 markdown-mode nftables-mode rustic lsp-mode lsp-ui
173 direnv company projectile tomorrow-night-paradise-theme 174 direnv company projectile tomorrow-night-paradise-theme
174 treesit-grammars.with-all-grammars 175 treesit-grammars.with-all-grammars magit-delta
175 ]; 176 ];
176 overrides = self: super: { 177 overrides = self: super: {
177 tomorrow-night-paradise-theme = super.trivialBuild { 178 tomorrow-night-paradise-theme = super.trivialBuild {
@@ -275,7 +276,7 @@ in {
275 output = "eDP-1"; 276 output = "eDP-1";
276 modules-left = [ "hyprland/workspaces" ]; 277 modules-left = [ "hyprland/workspaces" ];
277 modules-center = [ "hyprland/window" ]; 278 modules-center = [ "hyprland/window" ];
278 modules-right = [ "custom/weather" "custom/keymap" "clock" "privacy" "tray" "wireplumber" "backlight" "battery" "idle_inhibitor" ]; 279 modules-right = [ "custom/weather" "custom/keymap" "privacy" "tray" "wireplumber" "backlight" "battery" "idle_inhibitor" "clock" ];
279 280
280 "custom/weather" = { 281 "custom/weather" = {
281 format = "{}"; 282 format = "{}";
@@ -301,7 +302,7 @@ in {
301 if keymap == "English (programmer Dvorak)": 302 if keymap == "English (programmer Dvorak)":
302 short = "dvp" 303 short = "dvp"
303 elif keymap == "English (US)": 304 elif keymap == "English (US)":
304 short = "us" 305 short = "<span color=\"#ffffff\">us</span>"
305 print(json.dumps({'text': short, 'tooltip': keymap}, separators=(',', ':')), flush=True) # noqa: E501 306 print(json.dumps({'text': short, 'tooltip': keymap}, separators=(',', ':')), flush=True) # noqa: E501
306 307
307 308
@@ -471,6 +472,13 @@ in {
471 472
472 #custom-weather, #custom-keymap { 473 #custom-weather, #custom-keymap {
473 color: @grey; 474 color: @grey;
475 margin: 0 5px;
476 }
477 #custom-weather {
478 margin-right: 3px;
479 }
480 #custom-keymap {
481 margin-left: 3px;
474 } 482 }
475 483
476 #tray { 484 #tray {
@@ -480,6 +488,13 @@ in {
480 color: @grey; 488 color: @grey;
481 margin: 0 5px 0 2px; 489 margin: 0 5px 0 2px;
482 } 490 }
491 #idle_inhibitor {
492 margin-right: 2px;
493 margin-left: 3px;
494 }
495 #battery {
496 margin-right: 3px;
497 }
483 #battery.discharging { 498 #battery.discharging {
484 color: @white; 499 color: @white;
485 } 500 }
@@ -505,7 +520,7 @@ in {
505 margin: -1px 2px 0px 5px; 520 margin: -1px 2px 0px 5px;
506 } 521 }
507 #clock { 522 #clock {
508 margin-right: 5px; 523 /* margin-right: 5px; */
509 } 524 }
510 ''; 525 '';
511 }; 526 };
@@ -691,7 +706,6 @@ in {
691 ]; 706 ];
692 707
693 file = { 708 file = {
694 ".emacs.d/init.el".source = ./emacs.el;
695 ".backup-munin".source = ./backup-patterns; 709 ".backup-munin".source = ./backup-patterns;
696 ".mozilla/firefox/default/chrome/userChrome.css".source = ./firefox-chrome.css; 710 ".mozilla/firefox/default/chrome/userChrome.css".source = ./firefox-chrome.css;
697 ".mozilla/firefox/default/chrome/userContent.css".source = ./firefox-content.css; 711 ".mozilla/firefox/default/chrome/userContent.css".source = ./firefox-content.css;
@@ -757,6 +771,7 @@ in {
757 }; 771 };
758 }; 772 };
759 }; 773 };
774 "emacs/init.el".source = ./emacs.el;
760 }; 775 };
761 776
762 xdg.dataFile = { 777 xdg.dataFile = {