summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix60
1 files changed, 35 insertions, 25 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index 7d5a9c25..f4f7daed 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -80,7 +80,7 @@ let
80 ]; 80 ];
81 }; 81 };
82 82
83 lockCommand = "${config.systemd.package}/bin/systemctl --user start gtklock.service"; 83 lockCommand = "${lib.getExe' config.systemd.package "systemctl"} --user start gtklock.service";
84in { 84in {
85 imports = with flake.nixosModules.userProfiles.${userName}; [ 85 imports = with flake.nixosModules.userProfiles.${userName}; [
86 mpv yt-dlp (args: import ./xcompose.nix (inputs // args)) 86 mpv yt-dlp (args: import ./xcompose.nix (inputs // args))
@@ -185,7 +185,12 @@ in {
185 }; 185 };
186 }; 186 };
187 187
188 zathura.enable = true; 188 zathura = {
189 enable = true;
190 options = {
191 scroll-page-aware = true;
192 };
193 };
189 imv.enable = true; 194 imv.enable = true;
190 195
191 mpv.config = { 196 mpv.config = {
@@ -255,7 +260,7 @@ in {
255 enable = true; 260 enable = true;
256 settings.default = { 261 settings.default = {
257 path = "~/.wallpapers"; 262 path = "~/.wallpapers";
258 duration = "8h"; 263 duration = "15m";
259 mode = "center"; 264 mode = "center";
260 }; 265 };
261 }; 266 };
@@ -313,8 +318,11 @@ in {
313 device_mounted = []; 318 device_mounted = [];
314 }; 319 };
315 device_config = [ 320 device_config = [
316 { mount_path = "/run/etc-metadata"; ignore = true; } 321 { loop_file = "/nix/store/*-etc-metadata.erofs"; is_mounted = false; ignore = true; }
322 { mount_path = "/run/nixos-etc-metadata"; ignore = true; }
323 { mount_path = "/run/nixos-etc-metadata.*"; ignore = true; }
317 ]; 324 ];
325 icon_names.media = ["drive-removable-media-symbolic"];
318 }; 326 };
319 }; 327 };
320 network-manager-applet.enable = true; 328 network-manager-applet.enable = true;
@@ -351,31 +359,17 @@ in {
351 enable = true; 359 enable = true;
352 events = [ 360 events = [
353 { event = "before-sleep"; command = lockCommand; } 361 { event = "before-sleep"; command = lockCommand; }
354 # { event = "after-resume"; command = "${cfg.wayland.windowManager.hyprland.package}/bin/hyprctl dispatch dpms on"; }
355 { event = "lock"; command = lockCommand; } 362 { event = "lock"; command = lockCommand; }
356 ]; 363 ];
357 timeouts = [ 364 timeouts = [
358 # { timeout = 300;
359 # command = "${cfg.wayland.windowManager.hyprland.package}/bin/hyprctl dispatch dpms off";
360 # }
361 { timeout = 330; command = lockCommand; } 365 { timeout = 330; command = lockCommand; }
362 ]; 366 ];
363 extraArgs = [ 367 extraArgs = [
368 "-w"
364 "idlehint" "30" 369 "idlehint" "30"
365 ]; 370 ];
366 }; 371 };
367 poweralertd.enable = true; 372 poweralertd.enable = true;
368 avizo = {
369 enable = true;
370 settings.default = {
371 time = "1.0";
372 background = "rgba(0, 0, 0, 0.8)";
373 border-color = "rgba(0, 0, 0, 1)";
374 bar-fg-color = "rgba(160, 160, 160, 1)";
375 bar-bg-color = "rgba(32, 32, 32, 0.96)";
376 # y-offset = "0.25";
377 };
378 };
379 }; 373 };
380 374
381 home.pointerCursor = { 375 home.pointerCursor = {
@@ -416,16 +410,18 @@ in {
416 fira fira-code pwvucontrol wrappedKeepassxc wl-clipboard-rs 410 fira fira-code pwvucontrol wrappedKeepassxc wl-clipboard-rs
417 mumble pulseaudio-ctl pamixer libnotify screen-message 411 mumble pulseaudio-ctl pamixer libnotify screen-message
418 wrappedYTMDesktop libsForQt5.qt5ct playerctl evince 412 wrappedYTMDesktop libsForQt5.qt5ct playerctl evince
419 thunderbird zoom-us steam steam-run wireshark virt-manager 413 thunderbird zoom-us xdg-desktop-portal steam steam-run
420 rclone cached-nix-shell worktime fira-code-symbols 414 wireshark virt-manager rclone cached-nix-shell worktime
421 libreoffice xournalpp google-chrome nixos-shell virt-viewer 415 fira-code-symbols libreoffice xournalpp google-chrome
422 freerdp gnome-icon-theme paper-icon-theme sshpassSecret 416 nixos-shell virt-viewer freerdp gnome-icon-theme
423 weechat element-desktop matrix-synapse-tools.synadm 417 paper-icon-theme sshpassSecret weechat element-desktop
418 matrix-synapse-tools.synadm
424 flakeInputs.deploy-rs.packages.${config.nixpkgs.system}.deploy-rs 419 flakeInputs.deploy-rs.packages.${config.nixpkgs.system}.deploy-rs
425 sieve-connect gimp inkscape udiskie glab nitrokey-app 420 sieve-connect gimp inkscape udiskie glab nitrokey-app
426 pynitrokey gtklock wlrctl remmina openscad spice-record 421 pynitrokey gtklock wlrctl remmina openscad spice-record
427 libguestfs-with-appliance nerd-fonts.fira-mono 422 libguestfs-with-appliance nerd-fonts.fira-mono
428 nerd-fonts.symbols-only nerd-fonts.fira-code powerline-fonts 423 nerd-fonts.symbols-only nerd-fonts.fira-code powerline-fonts
424 swtpm
429 ]; 425 ];
430 426
431 file = { 427 file = {
@@ -491,6 +487,18 @@ in {
491 }; 487 };
492 }; 488 };
493 "emacs/init.el".source = ./emacs.el; 489 "emacs/init.el".source = ./emacs.el;
490 "systemd/user/xdg-desktop-portal.service.d/after-graphical-session.conf".text = ''
491 [Unit]
492 After=graphical-session.target
493 '';
494 "systemd/user/home-manager.service.d/before-graphical-session.conf".text = ''
495 [Unit]
496 Before=graphical-session-pre.target
497 '';
498 "pdfpc/pdfpcrc".text = ''
499 mouse 8 prev
500 mouse 9 next
501 '';
494 }; 502 };
495 503
496 xdg.dataFile = { 504 xdg.dataFile = {
@@ -608,7 +616,6 @@ in {
608 --property 'CPUAccounting=yes' --property 'CPUQuotaPeriodSec=50ms' \ 616 --property 'CPUAccounting=yes' --property 'CPUQuotaPeriodSec=50ms' \
609 --property 'Environment=DSCP=46' \ 617 --property 'Environment=DSCP=46' \
610 -- ${pkgs.dscp}/bin/dscp ${pkgs.google-chrome}/bin/google-chrome-stable \ 618 -- ${pkgs.dscp}/bin/dscp ${pkgs.google-chrome}/bin/google-chrome-stable \
611 --force-device-scale-factor=1.5 \
612 --class=Rainbow \ 619 --class=Rainbow \
613 --kiosk "https://web.openrainbow.com" \ 620 --kiosk "https://web.openrainbow.com" \
614 --user-data-dir=''${HOME}/.config/google-chrome-rainbow 621 --user-data-dir=''${HOME}/.config/google-chrome-rainbow
@@ -617,6 +624,9 @@ in {
617 url = "https://web.openrainbow.com/rb/2.139.17/assets/skins/rainbow/images/homepage/logo__rainbow.svg"; 624 url = "https://web.openrainbow.com/rb/2.139.17/assets/skins/rainbow/images/homepage/logo__rainbow.svg";
618 hash = "sha256-5fmo8rDqVDpzkGaPjk4Y+SsSZpAsY7VUQSFW6WdHwuU="; 625 hash = "sha256-5fmo8rDqVDpzkGaPjk4Y+SsSZpAsY7VUQSFW6WdHwuU=";
619 }; 626 };
627 settings = {
628 StartupWMClass = "Rainbow";
629 };
620 }; 630 };
621 }; 631 };
622 632