summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix27
1 files changed, 10 insertions, 17 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index b47e25a4..58cfb425 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -80,7 +80,7 @@ let
80 ]; 80 ];
81 }; 81 };
82 82
83 lockCommand = "${config.systemd.package}/bin/systemctl --user start gtklock.service"; 83 lockCommand = "${lib.getExe' config.systemd.package "systemctl"} --user start gtklock.service";
84in { 84in {
85 imports = with flake.nixosModules.userProfiles.${userName}; [ 85 imports = with flake.nixosModules.userProfiles.${userName}; [
86 mpv yt-dlp (args: import ./xcompose.nix (inputs // args)) 86 mpv yt-dlp (args: import ./xcompose.nix (inputs // args))
@@ -319,6 +319,7 @@ in {
319 }; 319 };
320 device_config = [ 320 device_config = [
321 { loop_file = "/nix/store/*-etc-metadata.erofs"; is_mounted = false; ignore = true; } 321 { loop_file = "/nix/store/*-etc-metadata.erofs"; is_mounted = false; ignore = true; }
322 { mount_path = "/run/nixos-etc-metadata"; ignore = true; }
322 { mount_path = "/run/nixos-etc-metadata.*"; ignore = true; } 323 { mount_path = "/run/nixos-etc-metadata.*"; ignore = true; }
323 ]; 324 ];
324 icon_names.media = ["drive-removable-media-symbolic"]; 325 icon_names.media = ["drive-removable-media-symbolic"];
@@ -358,31 +359,17 @@ in {
358 enable = true; 359 enable = true;
359 events = [ 360 events = [
360 { event = "before-sleep"; command = lockCommand; } 361 { event = "before-sleep"; command = lockCommand; }
361 # { event = "after-resume"; command = "${cfg.wayland.windowManager.hyprland.package}/bin/hyprctl dispatch dpms on"; }
362 { event = "lock"; command = lockCommand; } 362 { event = "lock"; command = lockCommand; }
363 ]; 363 ];
364 timeouts = [ 364 timeouts = [
365 # { timeout = 300;
366 # command = "${cfg.wayland.windowManager.hyprland.package}/bin/hyprctl dispatch dpms off";
367 # }
368 { timeout = 330; command = lockCommand; } 365 { timeout = 330; command = lockCommand; }
369 ]; 366 ];
370 extraArgs = [ 367 extraArgs = [
368 "-w"
371 "idlehint" "30" 369 "idlehint" "30"
372 ]; 370 ];
373 }; 371 };
374 poweralertd.enable = true; 372 poweralertd.enable = true;
375 avizo = {
376 enable = true;
377 settings.default = {
378 time = "1.0";
379 background = "rgba(0, 0, 0, 0.8)";
380 border-color = "rgba(0, 0, 0, 1)";
381 bar-fg-color = "rgba(160, 160, 160, 1)";
382 bar-bg-color = "rgba(32, 32, 32, 0.96)";
383 # y-offset = "0.25";
384 };
385 };
386 }; 373 };
387 374
388 home.pointerCursor = { 375 home.pointerCursor = {
@@ -508,6 +495,10 @@ in {
508 [Unit] 495 [Unit]
509 Before=graphical-session-pre.target 496 Before=graphical-session-pre.target
510 ''; 497 '';
498 "pdfpc/pdfpcrc".text = ''
499 mouse 8 prev
500 mouse 9 next
501 '';
511 }; 502 };
512 503
513 xdg.dataFile = { 504 xdg.dataFile = {
@@ -625,7 +616,6 @@ in {
625 --property 'CPUAccounting=yes' --property 'CPUQuotaPeriodSec=50ms' \ 616 --property 'CPUAccounting=yes' --property 'CPUQuotaPeriodSec=50ms' \
626 --property 'Environment=DSCP=46' \ 617 --property 'Environment=DSCP=46' \
627 -- ${pkgs.dscp}/bin/dscp ${pkgs.google-chrome}/bin/google-chrome-stable \ 618 -- ${pkgs.dscp}/bin/dscp ${pkgs.google-chrome}/bin/google-chrome-stable \
628 --force-device-scale-factor=1.5 \
629 --class=Rainbow \ 619 --class=Rainbow \
630 --kiosk "https://web.openrainbow.com" \ 620 --kiosk "https://web.openrainbow.com" \
631 --user-data-dir=''${HOME}/.config/google-chrome-rainbow 621 --user-data-dir=''${HOME}/.config/google-chrome-rainbow
@@ -634,6 +624,9 @@ in {
634 url = "https://web.openrainbow.com/rb/2.139.17/assets/skins/rainbow/images/homepage/logo__rainbow.svg"; 624 url = "https://web.openrainbow.com/rb/2.139.17/assets/skins/rainbow/images/homepage/logo__rainbow.svg";
635 hash = "sha256-5fmo8rDqVDpzkGaPjk4Y+SsSZpAsY7VUQSFW6WdHwuU="; 625 hash = "sha256-5fmo8rDqVDpzkGaPjk4Y+SsSZpAsY7VUQSFW6WdHwuU=";
636 }; 626 };
627 settings = {
628 StartupWMClass = "Rainbow";
629 };
637 }; 630 };
638 }; 631 };
639 632