summaryrefslogtreecommitdiff
path: root/accounts/gkleen@eos.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@eos.nix')
-rw-r--r--accounts/gkleen@eos.nix25
1 files changed, 24 insertions, 1 deletions
diff --git a/accounts/gkleen@eos.nix b/accounts/gkleen@eos.nix
index c157af78..dbe48ead 100644
--- a/accounts/gkleen@eos.nix
+++ b/accounts/gkleen@eos.nix
@@ -1 +1,24 @@
1{ ... }: {} 1{ flake, userName, pkgs, ... }:
2{
3 imports = with flake.nixosModules.userProfiles.${userName}; [
4 zsh utils tmux
5 ];
6
7 config.home-manager.users.${userName} = {
8 nixpkgs.config = {
9 allowUnfree = true;
10 };
11
12 home.packages = with pkgs; [
13 thunderbird libreoffice element-desktop keepassxc
14 ];
15
16 programs.firefox = {
17 enable = true;
18 profiles.default.settings = {
19 "dom.security.https_only_mode" = true;
20 "browser.cache.disk.enable" = false;
21 };
22 };
23 };
24}