summaryrefslogtreecommitdiff
path: root/user-profiles/yt-dlp.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2021-11-03 09:52:52 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2021-11-03 09:52:52 +0100
commit128904cd3b9e6ecf7ee5a91564b0f0c67deb4530 (patch)
tree7306ba4558145b5f54311569199f04743951b571 /user-profiles/yt-dlp.nix
parent3b37f9780e11bb8a8f7320e7cf2ba7a5b6a4b89b (diff)
downloadnixos-128904cd3b9e6ecf7ee5a91564b0f0c67deb4530.tar
nixos-128904cd3b9e6ecf7ee5a91564b0f0c67deb4530.tar.gz
nixos-128904cd3b9e6ecf7ee5a91564b0f0c67deb4530.tar.bz2
nixos-128904cd3b9e6ecf7ee5a91564b0f0c67deb4530.tar.xz
nixos-128904cd3b9e6ecf7ee5a91564b0f0c67deb4530.zip
gkleen@sif: switch to yt-dlp
Diffstat (limited to 'user-profiles/yt-dlp.nix')
-rw-r--r--user-profiles/yt-dlp.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/user-profiles/yt-dlp.nix b/user-profiles/yt-dlp.nix
new file mode 100644
index 00000000..946fd8d0
--- /dev/null
+++ b/user-profiles/yt-dlp.nix
@@ -0,0 +1,17 @@
1{ config, lib, userName, pkgs, ... }:
2{
3 home-manager.users.${userName} = {
4 home.packages = with pkgs; [ yt-dlp ];
5 xdg.configFile."yt-dlp/config".text = ''
6 --netrc
7 --mark-watched
8 --format ${lib.concatStringsSep "/" [
9 "bestvideo[width<=1920][height<=1080][fps<=60][protocol!=http_dash_segments]+bestaudio[protocol!=http_dash_segments]"
10 "best[width<=1920][height<=1080][fps<=60][protocol!=http_dash_segments]"
11 # "bestvideo[width<=2560][height<=1440][fps<=60][protocol!=http_dash_segments]+bestaudio[protocol!=http_dash_segments]"
12 # "best[width<=2560][height<=1440][fps<=60][protocol!=http_dash_segments]"
13 "best[protocol!=http_dash_segments]"
14 ]}
15 '';
16 };
17}