summaryrefslogtreecommitdiff
path: root/user-profiles/core.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2023-01-13 21:06:39 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2023-01-13 21:06:39 +0100
commit7a63e7adc4f929d958cd6bb1d784b640a4af6eba (patch)
tree772705e701aac9de1bff506205c8b0d410ca8a35 /user-profiles/core.nix
parent79004a0077ad0d584859e39bf7ec881e4ae67999 (diff)
downloadnixos-7a63e7adc4f929d958cd6bb1d784b640a4af6eba.tar
nixos-7a63e7adc4f929d958cd6bb1d784b640a4af6eba.tar.gz
nixos-7a63e7adc4f929d958cd6bb1d784b640a4af6eba.tar.bz2
nixos-7a63e7adc4f929d958cd6bb1d784b640a4af6eba.tar.xz
nixos-7a63e7adc4f929d958cd6bb1d784b640a4af6eba.zip
home-manager late activation
Diffstat (limited to 'user-profiles/core.nix')
-rw-r--r--user-profiles/core.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/user-profiles/core.nix b/user-profiles/core.nix
index 29891d12..acd61b9a 100644
--- a/user-profiles/core.nix
+++ b/user-profiles/core.nix
@@ -1,15 +1,20 @@
1{ flake, userName, config, lib, utils, ... }: 1{ flake, userName, config, lib, utils, ... }:
2{ 2
3with lib;
4
5{
3 config = { 6 config = {
4 users.users.${userName} = {}; # Just make sure the user is created 7 users.users.${userName} = {}; # Just make sure the user is created
5 8
9 home-manager.useUserService = true;
6 home-manager.users.${userName} = { 10 home-manager.users.${userName} = {
7 imports = lib.attrValues flake.homeModules; 11 imports = lib.attrValues flake.homeModules;
8 12
9 config = { 13 config = {
10 manual.manpages.enable = true; 14 manual.manpages.enable = true;
11 home.stateVersion = "20.09";
12 systemd.user.startServices = "sd-switch"; 15 systemd.user.startServices = "sd-switch";
16
17 programs.ssh.internallyManaged = mkForce true;
13 }; 18 };
14 }; 19 };
15 20