summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2023-01-30 12:20:23 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2023-01-30 12:20:23 +0100
commitcfc871cce6aefaa0ff64619780a807cba761c6b2 (patch)
tree965e8276ed36f11698b6c7d6eadab9f88d5f97c5 /shell.nix
parentaa54fe89b98d354d21141c589332ce7950ef2e59 (diff)
downloadnixos-cfc871cce6aefaa0ff64619780a807cba761c6b2.tar
nixos-cfc871cce6aefaa0ff64619780a807cba761c6b2.tar.gz
nixos-cfc871cce6aefaa0ff64619780a807cba761c6b2.tar.bz2
nixos-cfc871cce6aefaa0ff64619780a807cba761c6b2.tar.xz
nixos-cfc871cce6aefaa0ff64619780a807cba761c6b2.zip
...
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 5f883cd1..c50c1991 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,10 +1,9 @@
1inputs@{ system, self, deploy-rs, nvfetcher, nixpkgs, ... }: 1inputs@{ system, self, deploy-rs, nvfetcher, nixpkgs, ca-util, ... }:
2let 2let
3 pkgs = self.legacyPackages.${system}; 3 pkgs = self.legacyPackages.${system};
4 utils = import ./utils { inherit (nixpkgs) lib; }; 4 utils = import ./utils { inherit (nixpkgs) lib; };
5 inherit (utils) nixImport; 5 inherit (utils) nixImport;
6in pkgs.mkShell { 6in pkgs.mkShell {
7 name = "nixos";
8 nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [ 7 nativeBuildInputs = builtins.attrValues self.packages.${system} ++ (with pkgs; [
9 sops 8 sops
10 wireguard-tools 9 wireguard-tools
@@ -14,5 +13,7 @@ in pkgs.mkShell {
14 knot-dns 13 knot-dns
15 yq 14 yq
16 nvfetcher.packages.${system}.default 15 nvfetcher.packages.${system}.default
16 ca-util.packages.${system}.ca
17 ]); 17 ]);
18
18} 19}