summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-10-03 17:15:36 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2022-10-03 17:15:36 +0200
commit9248259708bd6ade5e334a2cdfb29d2a20acb0dd (patch)
tree976a140d547557c8cdf98856510030fd35b83d1a /shell.nix
parent59e54bd97f70711573d321f2d2aeee5da46bf95d (diff)
downloadnixos-9248259708bd6ade5e334a2cdfb29d2a20acb0dd.tar
nixos-9248259708bd6ade5e334a2cdfb29d2a20acb0dd.tar.gz
nixos-9248259708bd6ade5e334a2cdfb29d2a20acb0dd.tar.bz2
nixos-9248259708bd6ade5e334a2cdfb29d2a20acb0dd.tar.xz
nixos-9248259708bd6ade5e334a2cdfb29d2a20acb0dd.zip
...
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix10
1 files changed, 0 insertions, 10 deletions
diff --git a/shell.nix b/shell.nix
index 05ba992b..6ada761e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,21 +1,11 @@
1{ pkgs ? import <nixpkgs> {}, deploy-rs, nvfetcher }: 1{ pkgs ? import <nixpkgs> {}, deploy-rs, nvfetcher }:
2let 2let
3 nixWithFlakes = pkgs.symlinkJoin {
4 name = "nix-with-flakes";
5 paths = [ pkgs.nixFlakes ];
6 buildInputs = [ pkgs.makeWrapper ];
7 postBuild = ''
8 wrapProgram $out/bin/nix --add-flags '--option experimental-features "nix-command flakes"'
9 '';
10 };
11
12 tai64dec = pkgs.writeShellScriptBin "tai64dec" '' 3 tai64dec = pkgs.writeShellScriptBin "tai64dec" ''
13 echo $((16#$(${pkgs.daemontools}/bin/tai64n <<<"" | ${pkgs.coreutils}/bin/tail -c +2 | ${pkgs.coreutils}/bin/head -c 16))) 4 echo $((16#$(${pkgs.daemontools}/bin/tai64n <<<"" | ${pkgs.coreutils}/bin/tail -c +2 | ${pkgs.coreutils}/bin/head -c 16)))
14 ''; 5 '';
15in pkgs.mkShell { 6in pkgs.mkShell {
16 name = "nixos"; 7 name = "nixos";
17 nativeBuildInputs = with pkgs; [ 8 nativeBuildInputs = with pkgs; [
18 nixWithFlakes
19 sops 9 sops
20 wireguard-tools 10 wireguard-tools
21 gup 11 gup