summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2020-12-31 14:26:32 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2020-12-31 14:26:32 +0100
commit1dc5dff82f609bd3074d99b5308c0a2df0d1b077 (patch)
treed369c9f6ff494fe936e62a41537c36d58b0ef98c /shell.nix
parent5e868ac30eefa04de215268cd10e06a32daa0e9b (diff)
downloadnixos-1dc5dff82f609bd3074d99b5308c0a2df0d1b077.tar
nixos-1dc5dff82f609bd3074d99b5308c0a2df0d1b077.tar.gz
nixos-1dc5dff82f609bd3074d99b5308c0a2df0d1b077.tar.bz2
nixos-1dc5dff82f609bd3074d99b5308c0a2df0d1b077.tar.xz
nixos-1dc5dff82f609bd3074d99b5308c0a2df0d1b077.zip
Set up template
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 00000000..2820eb1a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,16 @@
1{ pkgs ? import <nixpkgs> {} }:
2let
3 nixWithFlakes = pkgs.symlinkJoin {
4 name = "nix-with-flakes";
5 paths = [ pkgs.nixFlakes ];
6 buildInputs = [ pkgs.makeWrapper ];
7 postBuild = ''
8 wrapProgram $out/bin/nix --add-flags '--option experimental-features "nix-command flakes ca-references"'
9 '';
10 };
11in pkgs.mkShell {
12 name = "nixos";
13 nativeBuildInputs = with pkgs; [
14 nixWithFlakes
15 ];
16}