summaryrefslogtreecommitdiff
path: root/overlays/inwx-cdnskey/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-02-27 16:48:41 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-02-27 16:48:41 +0100
commitc471ec95f8ccf0363cfae09c4479bf8e0907d065 (patch)
tree455f443e310587a6cec09447148855d204cce31c /overlays/inwx-cdnskey/default.nix
parentf8cec37ed3fda24dd3e834120b0f6dbcf95e54d2 (diff)
downloadnixos-c471ec95f8ccf0363cfae09c4479bf8e0907d065.tar
nixos-c471ec95f8ccf0363cfae09c4479bf8e0907d065.tar.gz
nixos-c471ec95f8ccf0363cfae09c4479bf8e0907d065.tar.bz2
nixos-c471ec95f8ccf0363cfae09c4479bf8e0907d065.tar.xz
nixos-c471ec95f8ccf0363cfae09c4479bf8e0907d065.zip
inwx-cdnskey
Diffstat (limited to 'overlays/inwx-cdnskey/default.nix')
-rw-r--r--overlays/inwx-cdnskey/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/overlays/inwx-cdnskey/default.nix b/overlays/inwx-cdnskey/default.nix
new file mode 100644
index 00000000..c19c2df5
--- /dev/null
+++ b/overlays/inwx-cdnskey/default.nix
@@ -0,0 +1,28 @@
1final: prev:
2let
3 packageOverrides = final.callPackage ./python-packages.nix {};
4 inpPython = final.python39.override { inherit packageOverrides; };
5in {
6 inwx-cdnskey = prev.stdenv.mkDerivation rec {
7 name = "inwx-cdnskey";
8 src = ./inwx-cdnskey.py;
9
10 phases = [ "buildPhase" "checkPhase" "installPhase" ];
11
12 python = inpPython.withPackages (ps: with ps; [pyxdg inwx-domrobot configparser dnspython]);
13
14 buildPhase = ''
15 substituteAll $src inwx-cdnskey
16 '';
17
18 doCheck = true;
19 checkPhase = ''
20 ${python}/bin/python -m py_compile inwx-cdnskey
21 '';
22
23 installPhase = ''
24 install -m 0755 -D -t $out/bin \
25 inwx-cdnskey
26 '';
27 };
28}