summaryrefslogtreecommitdiff
path: root/modules/yggdrasil-wg/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-11-01 21:05:33 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-11-01 21:05:33 +0100
commita73133a7c629c76a7a328f0e8d2bb693c46ef45d (patch)
tree11112e70dd44a3a1eb7fd1702c0b80baa578b386 /modules/yggdrasil-wg/default.nix
parent4188923d715bb4cfc3542eb05781fd45df85522e (diff)
downloadnixos-a73133a7c629c76a7a328f0e8d2bb693c46ef45d.tar
nixos-a73133a7c629c76a7a328f0e8d2bb693c46ef45d.tar.gz
nixos-a73133a7c629c76a7a328f0e8d2bb693c46ef45d.tar.bz2
nixos-a73133a7c629c76a7a328f0e8d2bb693c46ef45d.tar.xz
nixos-a73133a7c629c76a7a328f0e8d2bb693c46ef45d.zip
fix backups
Diffstat (limited to 'modules/yggdrasil-wg/default.nix')
-rw-r--r--modules/yggdrasil-wg/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/yggdrasil-wg/default.nix b/modules/yggdrasil-wg/default.nix
index c27eb286..8525cea0 100644
--- a/modules/yggdrasil-wg/default.nix
+++ b/modules/yggdrasil-wg/default.nix
@@ -82,7 +82,7 @@ let
82 mkPrivateKeyPath = family: host: ./hosts + "/${family}" + "/${host}.priv"; 82 mkPrivateKeyPath = family: host: ./hosts + "/${family}" + "/${host}.priv";
83 83
84 kernel = config.boot.kernelPackages; 84 kernel = config.boot.kernelPackages;
85 85
86 publicKeyPath = family: mkPublicKeyPath family hostName; 86 publicKeyPath = family: mkPublicKeyPath family hostName;
87 privateKeyPath = family: mkPrivateKeyPath family hostName; 87 privateKeyPath = family: mkPrivateKeyPath family hostName;
88 inNetwork' = family: pathExists (privateKeyPath family) && pathExists (publicKeyPath family); 88 inNetwork' = family: pathExists (privateKeyPath family) && pathExists (publicKeyPath family);
@@ -221,7 +221,7 @@ in {
221 }; 221 };
222 } 222 }
223 ] ++ (concatMap (router: map (rAddr: { routeConfig = { Destination = "::/0"; Gateway = stripSubnet rAddr; GatewayOnLink = true; Table = "yggdrasil"; }; }) batHostIPs.${router}) (filter (router: router != hostName) routers)); 223 ] ++ (concatMap (router: map (rAddr: { routeConfig = { Destination = "::/0"; Gateway = stripSubnet rAddr; GatewayOnLink = true; Table = "yggdrasil"; }; }) batHostIPs.${router}) (filter (router: router != hostName) routers));
224 routingPolicyRules = map (addr: { routingPolicyRuleConfig = { Table = "yggdrasil"; From = stripSubnet addr; Priority = 1; }; }) batHostIPs.${hostName}; 224 routingPolicyRules = map (addr: { routingPolicyRuleConfig = { Table = "yggdrasil"; From = addr; Priority = 1; }; }) batHostIPs.${hostName};
225 linkConfig = { 225 linkConfig = {
226 MACAddress = "${batHostMACs.${hostName}}"; 226 MACAddress = "${batHostMACs.${hostName}}";
227 RequiredForOnline = false; 227 RequiredForOnline = false;