summaryrefslogtreecommitdiff
path: root/hosts/sif/hw.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2024-07-30 15:22:50 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2024-07-30 15:22:50 +0200
commitbf329299d3c412bdbe6d1145b0947e6950c5c548 (patch)
treeced74c587ea71ad41df5258255fae7415a4a682e /hosts/sif/hw.nix
parentcd3c763cadbe887d5918f91619a836227d9e3846 (diff)
downloadnixos-bf329299d3c412bdbe6d1145b0947e6950c5c548.tar
nixos-bf329299d3c412bdbe6d1145b0947e6950c5c548.tar.gz
nixos-bf329299d3c412bdbe6d1145b0947e6950c5c548.tar.bz2
nixos-bf329299d3c412bdbe6d1145b0947e6950c5c548.tar.xz
nixos-bf329299d3c412bdbe6d1145b0947e6950c5c548.zip
...
Diffstat (limited to 'hosts/sif/hw.nix')
-rw-r--r--hosts/sif/hw.nix76
1 files changed, 58 insertions, 18 deletions
diff --git a/hosts/sif/hw.nix b/hosts/sif/hw.nix
index 3442a93a..bd3aa0de 100644
--- a/hosts/sif/hw.nix
+++ b/hosts/sif/hw.nix
@@ -1,25 +1,65 @@
1{ config, lib, pkgs, ... }: 1{ config, lib, pkgs, ... }:
2 2
3{ 3{
4 fileSystems."/" = 4 fileSystems = {
5 { device = "/dev/disk/by-uuid/f094bf06-66f9-40a8-9ab2-2b54d05223d2"; 5 "/boot" =
6 fsType = "btrfs"; 6 { device = "LABEL=boot";
7 }; 7 fsType = "vfat";
8 options = [ "fmask=0022" "dmask=0022" ];
9 };
10 "/.bcachefs" =
11 { device = "LABEL=sif";
12 fsType = "bcachefs";
13 neededForBoot = true;
14 };
15 "/nix" =
16 { device = "/.bcachefs/nix";
17 fsType = "none";
18 options = [ "bind" ];
19 };
20 "/root" =
21 { device = "/.bcachefs/root";
22 fsType = "none";
23 options = [ "bind" ];
24 };
25 "/var/log" =
26 { device = "/.bcachefs/var/log";
27 fsType = "none";
28 options = [ "bind" ];
29 };
30 "/var/lib/sops-nix" =
31 { device = "/.bcachefs/var/lib/sops-nix";
32 fsType = "none";
33 options = [ "bind" ];
34 neededForBoot = true;
35 };
36 "/var/lib/nixos" =
37 { device = "/.bcachefs/var/lib/nixos";
38 fsType = "none";
39 options = [ "bind" ];
40 neededForBoot = true;
41 };
42 "/var/lib/chrony" =
43 { device = "/.bcachefs/var/lib/chrony";
44 fsType = "none";
45 options = [ "bind" ];
46 };
47 "/var/lib/systemd" =
48 { device = "/.bcachefs/var/lib/systemd";
49 fsType = "none";
50 options = [ "bind" ];
51 neededForBoot = true;
52 };
53 "/home" =
54 { device = "/.bcachefs/home";
55 fsType = "none";
56 options = [ "bind" ];
57 };
58 };
8 59
9 fileSystems."/boot" = 60 swapDevices = [
10 { device = "/dev/disk/by-uuid/B3A2-D029"; 61 { device = "LABEL=swap"; }
11 fsType = "vfat"; 62 ];
12 };
13
14 fileSystems."/home" =
15 { device = "/dev/disk/by-uuid/9e932072-3c56-4a9c-8da7-3163d2a8bf28";
16 fsType = "btrfs";
17 };
18
19 fileSystems."/var/media" =
20 { device = "/dev/disk/by-uuid/437eca70-d017-4d52-a1fa-2f4c7a87f096";
21 fsType = "btrfs";
22 };
23 63
24 nix.settings.max-jobs = 12; 64 nix.settings.max-jobs = 12;
25 # High-DPI console 65 # High-DPI console