summaryrefslogtreecommitdiff
path: root/hosts/sif/default.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-02-21 16:48:51 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-02-21 16:48:51 +0100
commit52dd9a4d4cf13d0c8b189f06d3c5832a11813470 (patch)
tree40badd2180d8077a3dfbc941983c624efc9d48fb /hosts/sif/default.nix
parenta13ac830aedb7577ba9c1059a64f81a578bbb6a4 (diff)
downloadnixos-52dd9a4d4cf13d0c8b189f06d3c5832a11813470.tar
nixos-52dd9a4d4cf13d0c8b189f06d3c5832a11813470.tar.gz
nixos-52dd9a4d4cf13d0c8b189f06d3c5832a11813470.tar.bz2
nixos-52dd9a4d4cf13d0c8b189f06d3c5832a11813470.tar.xz
nixos-52dd9a4d4cf13d0c8b189f06d3c5832a11813470.zip
sif: wireplumber
Diffstat (limited to 'hosts/sif/default.nix')
-rw-r--r--hosts/sif/default.nix30
1 files changed, 1 insertions, 29 deletions
diff --git a/hosts/sif/default.nix b/hosts/sif/default.nix
index a74c9184..5ef6cc8e 100644
--- a/hosts/sif/default.nix
+++ b/hosts/sif/default.nix
@@ -332,35 +332,7 @@ in {
332 alsa.support32Bit = true; 332 alsa.support32Bit = true;
333 pulse.enable = true; 333 pulse.enable = true;
334 jack.enable = true; 334 jack.enable = true;
335 335 wireplumber.enable = true;
336 media-session = {
337 enable = true;
338 config.bluez-monitor.rules = [
339 { # Matches all cards
340 matches = [ { "device.name" = "~bluez_card.*"; } ];
341 actions = {
342 "update-props" = {
343 "bluez5.reconnect-profiles" = [ "hfp_hf" "hsp_hs" "a2dp_sink" ];
344 # mSBC is not expected to work on all headset + adapter combinations.
345 "bluez5.msbc-support" = true;
346 };
347 };
348 }
349 {
350 matches = [
351 # Matches all sources
352 { "node.name" = "~bluez_input.*"; }
353 # Matches all outputs
354 { "node.name" = "~bluez_output.*"; }
355 ];
356 actions = {
357 "update-props" = {
358 "node.pause-on-idle" = false;
359 };
360 };
361 }
362 ];
363 };
364 }; 336 };
365 337
366 hardware = { 338 hardware = {