diff options
author | Gregor Kleen <gkleen@yggdrasil.li> | 2022-05-15 14:41:49 +0200 |
---|---|---|
committer | Gregor Kleen <gkleen@yggdrasil.li> | 2022-05-15 14:41:49 +0200 |
commit | 355b6d4ec02ad535b93ce314dd5734e8c6028dbc (patch) | |
tree | 401e8e871f65e9b4fb153efc971f21c5323910af /flake.nix | |
parent | c4b323d77c1f34b294406052d598c6a37a045765 (diff) | |
download | nixos-355b6d4ec02ad535b93ce314dd5734e8c6028dbc.tar nixos-355b6d4ec02ad535b93ce314dd5734e8c6028dbc.tar.gz nixos-355b6d4ec02ad535b93ce314dd5734e8c6028dbc.tar.bz2 nixos-355b6d4ec02ad535b93ce314dd5734e8c6028dbc.tar.xz nixos-355b6d4ec02ad535b93ce314dd5734e8c6028dbc.zip |
surtr: ...
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 8 |
1 files changed, 4 insertions, 4 deletions
@@ -210,10 +210,10 @@ | |||
210 | system = { | 210 | system = { |
211 | path = deploy-rs.lib.${self.nixosConfigurations.${hostname}.config.nixpkgs.system}.activate.nixos self.nixosConfigurations.${hostname}; | 211 | path = deploy-rs.lib.${self.nixosConfigurations.${hostname}.config.nixpkgs.system}.activate.nixos self.nixosConfigurations.${hostname}; |
212 | }; | 212 | }; |
213 | } // (mapAttrs (_user: usercfg: { | 213 | }; # // (mapAttrs (_user: usercfg: { |
214 | user = usercfg.home.username; | 214 | # user = usercfg.home.username; |
215 | path = activateHomeManager (self.nixosConfigurations.${hostname}.config.nixpkgs.system) usercfg.home; | 215 | # path = activateHomeManager (self.nixosConfigurations.${hostname}.config.nixpkgs.system) usercfg.home; |
216 | }) self.nixosConfigurations.${hostname}.config.home-manager.users); | 216 | # }) self.nixosConfigurations.${hostname}.config.home-manager.users); |
217 | }) (nixImport { dir = ./hosts; _import = (_path: name: name); }); | 217 | }) (nixImport { dir = ./hosts; _import = (_path: name: name); }); |
218 | overrides = if pathExists ./deploy then nixImport { dir = ./deploy; _import = path: _name: import (./deploy + "/${path}") inputs; } else {}; | 218 | overrides = if pathExists ./deploy then nixImport { dir = ./deploy; _import = path: _name: import (./deploy + "/${path}") inputs; } else {}; |
219 | filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs); | 219 | filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs); |