summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2021-01-02 16:21:34 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2021-01-02 16:21:34 +0100
commit8c946f2d3b36c8e34c1fba4df314f03b74d25a34 (patch)
tree30c6e81af8fbfc1473a3eeadf02542680437188e /flake.nix
parentee48cee0393d20c5d1121675288e041834a9285c (diff)
downloadnixos-8c946f2d3b36c8e34c1fba4df314f03b74d25a34.tar
nixos-8c946f2d3b36c8e34c1fba4df314f03b74d25a34.tar.gz
nixos-8c946f2d3b36c8e34c1fba4df314f03b74d25a34.tar.bz2
nixos-8c946f2d3b36c8e34c1fba4df314f03b74d25a34.tar.xz
nixos-8c946f2d3b36c8e34c1fba4df314f03b74d25a34.zip
fix user-profiles
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index 83f92ac6..52d4026d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -79,7 +79,7 @@
79 (inputs: inputs // { inherit userName; }) 79 (inputs: inputs // { inherit userName; })
80 (outputs: { _file = dir + "/${path}"; } 80 (outputs: { _file = dir + "/${path}"; }
81 // outputs 81 // outputs
82 // { imports = [self.nixosModules.userProfiles.${userName}.core] ++ (outputs.imports or []); }); 82 // { imports = defaultUserProfiles userName ++ (outputs.imports or []); });
83 83
84 mkUserProfile = userName: dir: path: profileName: 84 mkUserProfile = userName: dir: path: profileName:
85 let 85 let
@@ -102,7 +102,7 @@
102 (inputs: inputs // { inherit userName; }) 102 (inputs: inputs // { inherit userName; })
103 (outputs: { _file = dir + "/${path}"; } 103 (outputs: { _file = dir + "/${path}"; }
104 // outputs 104 // outputs
105 // { imports = defaultUserProfiles userName ++ (outputs.imports or []); }); 105 // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); });
106 106
107 forAllSystems = f: mapAttrs f nixpkgs.legacyPackages; 107 forAllSystems = f: mapAttrs f nixpkgs.legacyPackages;
108 forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts))); 108 forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts)));