diff options
author | Gregor Kleen <gkleen@yggdrasil.li> | 2025-01-14 15:05:32 +0100 |
---|---|---|
committer | Gregor Kleen <gkleen@yggdrasil.li> | 2025-01-14 15:05:40 +0100 |
commit | c744867b5adc417748f6ed6fdb17cb6e4c6fc46b (patch) | |
tree | cc970543a9e601244f5fab956f52e999b686f4a1 /flake.nix | |
parent | 21b52a31e1eff5c8142f26e091fde083c21db55f (diff) | |
download | nixos-c744867b5adc417748f6ed6fdb17cb6e4c6fc46b.tar nixos-c744867b5adc417748f6ed6fdb17cb6e4c6fc46b.tar.gz nixos-c744867b5adc417748f6ed6fdb17cb6e4c6fc46b.tar.bz2 nixos-c744867b5adc417748f6ed6fdb17cb6e4c6fc46b.tar.xz nixos-c744867b5adc417748f6ed6fdb17cb6e4c6fc46b.zip |
...
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -189,6 +189,10 @@ | |||
189 | owner = "sodiboo"; | 189 | owner = "sodiboo"; |
190 | repo = "niri-flake"; | 190 | repo = "niri-flake"; |
191 | ref = "main"; | 191 | ref = "main"; |
192 | inputs = { | ||
193 | nixpkgs.follows = "nixpkgs"; | ||
194 | niri-unstable.url = "github:gkleen/niri"; | ||
195 | }; | ||
192 | }; | 196 | }; |
193 | }; | 197 | }; |
194 | 198 | ||
@@ -275,9 +279,10 @@ | |||
275 | mkAccountModule = dir: path: accountName: | 279 | mkAccountModule = dir: path: accountName: |
276 | let | 280 | let |
277 | userName = accountUserName accountName; | 281 | userName = accountUserName accountName; |
282 | hostName = accountHostName accountName; | ||
278 | in overrideModule | 283 | in overrideModule |
279 | (import (dir + "/${path}")) | 284 | (import (dir + "/${path}")) |
280 | (inputs: inputs // { inherit userName; }) | 285 | (inputs: inputs // { inherit userName hostName; }) |
281 | (outputs: { _file = dir + "/${path}"; } | 286 | (outputs: { _file = dir + "/${path}"; } |
282 | // outputs | 287 | // outputs |
283 | // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); | 288 | // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); |