summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-02-27 14:11:26 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-02-27 14:11:26 +0100
commit9c03c3a5b97d9712aaab2823daea63580f60b975 (patch)
treeb82a6af54b5ec8bf840a3964b1a8db6b9a9f2a21 /flake.nix
parent0d09be5b612ca2c9f180a511a38ff05f69f3da33 (diff)
downloadnixos-9c03c3a5b97d9712aaab2823daea63580f60b975.tar
nixos-9c03c3a5b97d9712aaab2823daea63580f60b975.tar.gz
nixos-9c03c3a5b97d9712aaab2823daea63580f60b975.tar.bz2
nixos-9c03c3a5b97d9712aaab2823daea63580f60b975.tar.xz
nixos-9c03c3a5b97d9712aaab2823daea63580f60b975.zip
bump
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index e6ce4b05..1ef81d4c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -111,7 +111,7 @@
111 // outputs 111 // outputs
112 // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); 112 // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); });
113 113
114 systemsSelector = "(x86_64|i686)-linux"; 114 systemsSelector = "x86_64-linux";
115 forAllSystems = f: mapAttrs f (filterAttrs (system: _systemPkgs: !(isNull (builtins.match systemsSelector system))) nixpkgs.legacyPackages); 115 forAllSystems = f: mapAttrs f (filterAttrs (system: _systemPkgs: !(isNull (builtins.match systemsSelector system))) nixpkgs.legacyPackages);
116 forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts))); 116 forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts)));
117 117